Scenario: Timeout con il comando "hbase hbck" in Azure HDInsight
Questo articolo descrive le procedure di risoluzione dei problemi e le possibili soluzioni per i problemi che si verificano quando si interagisce con i cluster Azure HDInsight.
Problema
Durante la correzione delle assegnazioni di area, si verificano timeout con il comando hbase hbck
.
Causa
Un possibile causa dei problemi di timeout quando si usa il comando hbck
potrebbe essere che diverse aree restano a lungo in stato di transizione. Queste aree vengono visualizzate come offline nell'interfaccia utente di HBase Master. HBase Master può raggiungere il time out a causa del numero elevato di aree che tentano la transizione, senza riuscire a riportare online tali aree.
Risoluzione
Accedere al cluster HBase di HDInsight tramite SSH.
Eseguire il comando
hbase zkcli
per connettersi alla shell Apache ZooKeeper.Eseguire il comando
rmr /hbase/regions-in-transition
ormr /hbase-unsecure/regions-in-transition
.Uscire dalla shell
hbase zkcli
usando il comandoexit
.Dall'interfaccia utente di Apache Ambari riavviare il servizio HBase Master attivo.
Eseguire il comando
hbase hbck -fixAssignments
.Monitorare la sezione "area in transizione" nell'interfaccia utente di HBase Master per assicurarsi che nessuna area resti bloccata.
Passaggi successivi
Se il problema riscontrato non è presente in questo elenco o se non si riesce a risolverlo, visitare uno dei canali seguenti per ottenere ulteriore assistenza:
Ricevere risposte dagli esperti di Azure tramite la pagina Supporto della community per Azure.
Connettersi con @AzureSupport, l'account ufficiale Microsoft Azure per migliorare l'esperienza del cliente. Mette in contatto la community di Azure con le risorse giuste: risposte, supporto ed esperti.
Se serve ulteriore assistenza, è possibile inviare una richiesta di supporto dal portale di Azure. Selezionare Supporto nella barra dei menu o aprire l'hub Guida e supporto. Per informazioni più dettagliate, vedere Come creare una richiesta di supporto in Azure. L'accesso al supporto per la gestione delle sottoscrizioni e la fatturazione è incluso nella sottoscrizione di Microsoft Azure e il supporto tecnico viene fornito tramite uno dei piani di supporto di Azure.