Utilisateur standard : RunOnce et RunOnceEx ne sont pas exécutés
Cet article fournit de l’aide pour résoudre un problème où les utilisateurs standard ne peuvent pas exécuter un jeu de commandes via RunOnce ou RunOnceEx.
Applicabilité : Windows 10 - Toutes les éditions
Numéro de base de connaissances d’origine : 2021405
Symptômes
Une commande définie pour s’exécuter via RunOnce ou RunOnceEx peut ne pas s’exécuter comme prévu. Les clés de Registre affectées sont les suivantes :
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\RunOnce
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\RunOnceEx
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Runonce
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\RunonceEx
Cause
Cela se produit si vous vous connectez avec un compte d’utilisateur Standard. C'est la procédure normale.
Résolution
Pour exécuter des commandes à partir de ces clés de Registre, vous devez vous connecter avec un compte Administrateur. Ce problème affecte uniquement les utilisateurs disposant d’un compte d’utilisateur standard. Si l’utilisateur dispose d’un administrateur ou d’un jeton fractionné, l’exécution se poursuit.