Des erreurs de connexion intermittentes se produisent lors de l’ajout d’un nœud à l’environnement Always On dans SQL Server
Vous rencontrez des erreurs de connexion intermittentes lorsque vous ajoutez un nouveau nœud à l’environnement Always On existant.
Symptômes
Lorsque vous essayez de vous connecter à un serveur exécutant Microsoft SQL Server, le message d’erreur suivant s’affiche par intermittence :
La connexion a été établie avec le serveur, mais une erreur s’est produite pendant le processus de connexion. (fournisseur : Fournisseur SSL, erreur : 0 - Une connexion existante a été fermée de force par l’hôte distant.)
Cause
Cette erreur peut se produire s’il existe une incompatibilité dans les protocoles de sécurité entre la base de données et les serveurs d’applications.
Résolution
Pour corriger cette erreur, résolvez l’incompatibilité entre les protocoles de sécurité. Node1 chiffre les informations à l’aide d’AES128/256. Node2 chiffre les informations à l’aide de RC4. Pour résoudre cette erreur, procédez comme suit :
Téléchargez IIS Crypto.
Installez la version gui de l’outil IIS Crypto sur le serveur.
Configurer lesSuites de chiffrement.
Ouvrez l’outil IIS Crypto sur le serveur.
Dans l’interface IIS Crypto, sélectionnez Suites de chiffrement dans le volet gauche.
Dans la liste, décochez toutes les cases pour les chiffrements commençant par « TLS_DHE* ».
Note
La liste peut ne pas être dans un ordre particulier.
Après avoir effacé les sélections de chiffrement pertinentes, sélectionnez Appliquer pour enregistrer les modifications.
Redémarrez le serveur.
Une fois les modifications appliquées, redémarrez le serveur pour vous assurer que la nouvelle configuration de la suite de chiffrement prend effet.
Note
Ce processus de résolution des problèmes force le client à communiquer à l’aide d’une autre suite de chiffrement qui a une implémentation de sécurité améliorée.
Veillez toujours à disposer des sauvegardes appropriées. Envisagez également de tester les modifications apportées à un environnement contrôlé, intermédiaire ou de test avant de les appliquer aux ordinateurs de production. Si le problème persiste ou si vous rencontrez d’autres problèmes, contactez votre équipe réseau.
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