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Des erreurs de connexion intermittentes se produisent lors de l’ajout d’un nœud à l’environnement Always On dans SQL Server

Vous rencontrez des erreurs de connexion intermittentes lorsque vous ajoutez un nouveau nœud à l’environnement Always On existant.

Symptômes

Lorsque vous essayez de vous connecter à un serveur qui exécute Microsoft SQL Server, le message d’erreur suivant s’affiche par intermittence :

La connexion a été établie avec le serveur, mais une erreur s’est produite pendant le processus de connexion. (fournisseur : fournisseur SSL, erreur : 0 - Une connexion existante a été fermée de force par l’hôte distant.)

Cause

Cette erreur peut se produire en cas d’incompatibilité dans les protocoles de sécurité entre la base de données et les serveurs d’applications.

Résolution

Pour corriger cette erreur, résolvez l’incompatibilité entre les protocoles de sécurité. Node1 chiffre les informations à l’aide d’AES128/256. Node2 chiffre les informations à l’aide de RC4. Pour résoudre cette erreur, procédez comme suit :

  1. Téléchargez IIS Crypto.

  2. Installez la version gui de l’outil IIS Crypto sur le serveur.

  3. Configurez les suites de chiffrement.

  4. Ouvrez l’outil Iis Crypto sur le serveur.

  5. Dans l’interface IIS Crypto, sélectionnez Suites de chiffrement dans le volet gauche.

  6. Dans la liste, décochez toutes les cases pour les chiffrements qui commencent par « TLS_DHE* ».

    Remarque

    La liste peut ne pas être dans un ordre particulier.

  7. Après avoir effacé les sélections de chiffrement pertinentes, sélectionnez Appliquer pour enregistrer les modifications.

    Capture d’écran montrant l’effacement de tous les chiffrements qui ne sont pas requis.

  8. Redémarrez le serveur.

    Une fois les modifications appliquées, redémarrez le serveur pour vous assurer que la nouvelle configuration de la suite de chiffrement prend effet.

Remarque

Ce processus de résolution des problèmes force le client à communiquer à l’aide d’une suite de chiffrement différente qui a une implémentation de sécurité améliorée.

Vérifiez toujours que les sauvegardes appropriées sont disponibles. Envisagez également de tester les modifications dans un environnement contrôlé, intermédiaire ou de test avant de les appliquer aux ordinateurs de production. Si le problème persiste ou si vous avez d’autres problèmes, contactez votre équipe réseau.

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