Une erreur de connexion 10054 peut se produire après la mise à niveau de SQL Server
Après une mise à niveau de Microsoft SQL Server, vous rencontrez une erreur de connexion. L’erreur est susceptible de continuer même après avoir utilisé le compte système local pour le service SQL Server Agent.
Symptômes
Après avoir mis à niveau Microsoft SQL Server Édition Standard (STD), SQL Server Agent démarre et s’arrête immédiatement. En outre, vous recevez un ou plusieurs des messages d’erreur suivants :
SQL Server n’accepte pas la connexion (erreur : 10054). En attendant que SQL Server autorise les connexions. L’opération a été tentée : Vérifier la connexion au démarrage.
Erreur SQLServer : 10054, fournisseur SSL : une connexion existante a été fermée de force par l’hôte distant. [SQLSTATE 08001]
Erreur SQLServer : 10054, le client ne peut pas établir de connexion [SQLSTATE 08001]
Cause
Parfois après une mise à niveau de Microsoft SQL Server, TLS est désactivé et vous risquez d’rencontrer une erreur de connexion. Vérifiez si le protocole TLS est désactivé une fois la mise à niveau installée.
Résolution
Pour résoudre cette erreur, effectuez les étapes suivantes :
Activez TLS en définissant les entrées de Registre suivantes :
Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\TLS1.0
Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\TLS1.1
Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\TLS1.2
Redémarrez l’ordinateur pour vous assurer que la modification est appliquée.