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Impossible de mettre à jour les enregistrements en raison d’un accès aux objets manquant dans Salesforce CRM

Cet article vous aide à résoudre les problèmes liés au fait que les utilisateurs ne peuvent pas mettre à jour les enregistrements CRM dans Microsoft Copilot for Sales en raison d’un accès aux objets manquant dans Salesforce CRM.

Remarque

Microsoft Sales Copilot est renommé Microsoft Copilot for Sales en janvier 2024. La capture d’écran de cet article sera bientôt mise à jour avec le nouveau nom.

Qui est concerné ?

Type d’exigence Description
Application cliente Complément Outlook Copilot for Sales
Plateforme Clients web et de bureau
Système d’exploitation Windows et Mac
Déploiement Géré par l’utilisateur et géré par l’administrateur
CRM Salesforce
Utilisateurs Utilisateurs essayant de mettre à jour un enregistrement CRM à partir de Copilot for Sales

Symptômes

Lorsqu’un utilisateur tente de mettre à jour un enregistrement CRM à partir du complément Copilot for Sales pour Outlook, le message d’erreur suivant s’affiche :

Pour mettre à jour Salesforce, demandez à modifier l’accès pour cet objet.

Erreur concernant l’impossibilité de mettre à jour les enregistrements en raison d’un accès aux objets manquant dans Salesforce CRM.

Cause

L’utilisateur n’a pas d’accès de modification à un objet dans Salesforce.

Lorsqu’un utilisateur tente de modifier un objet, Copilot for Sales vérifie si l’utilisateur dispose d’un accès en écriture à l’objet dans Salesforce. Si l’utilisateur n’a pas accès en écriture à l’objet, le message d’erreur s’affiche.

Vous pouvez vérifier si l’utilisateur n’a pas accès en écriture à l’entité est la cause racine du problème si vous voyez l’erreur suivante dans les journaux :

Exception thrown in VivaSalesContacts/UpdateContact -  
Microsoft.SalesProductivity.Common.Base.SPServiceException: Salesforce failed to complete task: Message: entity is deleted clientRequestId:<CLIENT REQUEST ID>-self --->  
System.Exception: {  
    "status": 400,  
    "message": "Object type contact is not supported. If you are attempting to use a custom object, be sure to append the '__c' after the entity name.  
                Please reference your WSDL or the describe call for the appropriate names\r\nclientRequestId: <CLIENT REQUEST ID>-self",  
    "error": null,  
    "source": "Salesforce.Common",  
    "errors": []  
} 

Dans le message d’erreur ci-dessus, Object type contact is not supported indique que l’utilisateur n’a pas accès en écriture à l’objet Contact .

Résolution

Pour résoudre le problème, vérifiez que l’utilisateur a :

  • Autorisations de niveau lecture ou écriture sur l’objet que l’utilisateur tente de modifier dans Salesforce.
  • Autorisations de lecture ou d’écriture sur tous les champs configurés pour la modification.

Pour plus d’informations sur la sécurité au niveau de l’objet, la sécurité au niveau du champ et la sécurité au niveau de l’enregistrement dans Salesforce, consultez Contrôler qui voit quoi. Vous pouvez également contacter votre administrateur Salesforce pour obtenir de l’aide sur la définition des autorisations d’objet dans les profils.

Plus d’informations

Si votre problème n’est toujours pas résolu, accédez au Copilot for Sales - Microsoft Community Hub pour contacter nos experts.

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