Résoudre les codes d’erreur de création de session pour une exécution de flux de bureau sans assistance
Cet article fournit des solutions en arrière-plan et potentielles aux SessionCreationError
SessionCreationErrorWithThirdPartyCredentialProvider
codes d’erreur qui peuvent se produire pendant une exécution de flux de bureau sans assistance dans Microsoft Power Automate.
S’applique à : Power Automate
Symptômes
Votre exécution de flux de bureau sans assistance peut échouer avec le code d’erreur ou SessionCreationErrorWithThirdPartyCredentialProvider
le SessionCreationError
code d’erreur.
Cause
Lorsqu’une session sans assistance est exécutée, Power Automate tente de créer une session RDP (Remote Desktop) sur l’ordinateur cible. Si cette création de session échoue, vous pouvez recevoir l’un des codes d’erreur suivants :
SessionCreationErrorWithThirdPartyCredentialProvider
Ce code d’erreur se produit parce que les logiciels tiers interfèrent avec la capacité de Power Automate à créer une session sur l’ordinateur. Power Automate ne prend pas en charge certains fournisseurs d’informations d’identification tiers.
Résolution
Pour résoudre le problème, contactez votre administrateur pour désinstaller le fournisseur d’informations d’identification que Power Automate ne prend pas en charge.
Vous trouverez la liste complète des fournisseurs d’informations d’identification (dont la plupart sont intégrés) sur votre ordinateur dans la clé de Registre suivante :
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Authentication\Credential Providers
Chaque sous-clé représente un fournisseur d’informations d’identification installé. Le tableau suivant répertorie les fournisseurs d’informations d’identification que Power Automate ne prend actuellement pas en charge. Si vous disposez de la clé de Registre suivante, collaborez avec votre administrateur système pour désinstaller le logiciel correspondant.
Nom | Nom de sous-clé |
---|---|
Réinitialisation du mot de passe du bureau SailPoint Technologies | 0094A34B-0BF0-4789-8B2D-8339E469D756 |
SessionCreationError
Ce code d’erreur se produit lorsqu’une création de session échoue pour une raison inconnue.
Résolution
Pour résoudre le problème :
- Assurez-vous que vous pouvez effectuer un bureau à distance vers l’ordinateur à partir d’un autre ordinateur sur votre réseau. Si vous utilisez Windows Server, vous pouvez essayer de bureau à distance pour « localhost » à partir de l’ordinateur local lui-même lorsqu’il est connecté en tant qu’autre compte. Si ces actions échouent, consultez la résolution générale des problèmes de connexion Bureau à distance.
- Si un avis juridique est activé pour la connexion, contactez votre administrateur système pour essayer de le désactiver. Pour voir si l’avis juridique est activé, ouvrez l’Éditeur du Registre et accédez à
Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System
. S’illegalnoticecaption
n’est pas vide oulegalnoticetext
n’est pas vide, contactez votre administrateur système pour désactiver l’avis juridique. - Vérifiez qu’aucun logiciel tiers n’est installé qui peut affecter la connexion ou interférer avec la création d’une connexion Bureau à distance.
- Si vous utilisez un compte de domaine (DOMAIN\user) pour vous connecter, les problèmes de connectivité avec le contrôleur de domaine peuvent empêcher l’ouverture de la session correctement. Collaborez avec votre administrateur système pour examiner les journaux de connectivité. Si vous êtes sur un appareil joint à Microsoft Entra ou Entra hybride, essayez d’utiliser un UPN (
user@domain.com
). Pour voir si vous pouvez utiliser un UPN, accédez à Démarrer>l’exécution et exécutez la commande dsregcmd /status. Si vous voyezAzureAdJoined: YES
sousDevice State
, essayez de modifier l’utilisateur spécifié dans la connexion auuser@domain.com
format.
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