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Résoudre les erreurs de file d’attente d’exécution de flux de bureau

Cet article fournit des solutions en arrière-plan et potentielles aux erreurs basées sur la file d’attente rencontrées pendant les exécutions de flux de bureau.

S’applique à : Power Automate
Numéro de base de connaissances d’origine : 5004537

Symptômes

Votre flux de bureau peut ne pas s’exécuter avec le code NoCandidateMachine d’erreur ou les détails de l’erreur « Aucun ordinateur capable d’exécuter le flux de bureau a été trouvé ».

Vous pouvez également recevoir l’un de ces codes de sous-erreur courants :

Cause

Quand aucune machine n’est disponible, Power Automate crée une file d’attente pour contenir les flux de bureau en attente d’exécution. Une fois qu’un ordinateur est disponible, l’exécution du flux de bureau suivante sera sélectionnée pour s’exécuter en fonction de la priorité et de l’heure de la demande. Si aucun ordinateur n’est disponible après six heures depuis sa demande, le flux de bureau expire et échoue avec un NoCandidateMachine code d’erreur.

Comme mentionné dans le message d’erreur, cette erreur signifie que l’orchestrateur ne trouve pas d’ordinateur disponible pour exécuter le flux de bureau. Cette erreur se produit avant le démarrage de l’exécution du flux de bureau.

Important

Power Automate met automatiquement à l’échelle le nombre de flux de bureau simultanés exécutés jusqu’à la valeur maximale prise en charge. La file d’attente de l’exécution de l’ordinateur suit une approche de première entrée et de première sortie, ce qui signifie que la première exécution reçue est la suivante à exécuter. Si toutes les machines disponibles ont atteint leur nombre maximal de sessions simultanées et ne peuvent pas exécuter l’exécution suivante dans la file d’attente, la file d’attente est bloquée jusqu’à ce qu’une machine devienne disponible pour exécuter l’exécution suivante dans la file d’attente.

SessionExistsForTheUserWhenUnattended

Cette erreur se produit lorsque vous essayez d’exécuter un flux de bureau sans assistance sur un ordinateur cible où l’utilisateur utilisé dans la connexion de flux de bureau est connecté.

Résolution

Pour résoudre le problème, déconnectez-vous de la session (une session verrouillée entraîne cette erreur) et vérifiez que vous n’êtes pas connecté avec le même utilisateur sur l’ordinateur.

UnattendedUserSessionDisconnected

Cette erreur se produit lorsque vous essayez d’exécuter un flux de bureau sans assistance sur un ordinateur cible où il existe une session déconnectée pour l’utilisateur utilisé dans la connexion de flux de bureau.

Résolution

Pour résoudre le problème, déconnectez-vous de la session déconnectée et vérifiez que vous n’êtes pas connecté avec le même utilisateur sur l’ordinateur.

UnattendedUserSessionLocked

Cette erreur se produit lorsque vous essayez d’exécuter un flux de bureau sans assistance sur un ordinateur cible où il existe une session verrouillée pour l’utilisateur utilisé dans la connexion de flux de bureau.

Résolution

Pour résoudre le problème, déconnectez-vous de la session verrouillée et vérifiez que vous n’êtes pas connecté avec le même utilisateur sur l’ordinateur.

AttendedUserSessionNotActive

Cette erreur se produit lorsque vous essayez d’exécuter un flux de bureau assisté sur un ordinateur cible sur lequel la session utilisateur est verrouillée ou déconnectée. Les flux de bureau assistés peuvent s’exécuter uniquement si l’ordinateur est déverrouillé sur une session où l’utilisateur actuel correspond à celui de la connexion de flux de bureau.

Résolution

Pour résoudre le problème,

  • Reconnectez-vous sur l’ordinateur avec l’utilisateur utilisé pour l’exécution suivie et laissez la session active sur l’ordinateur.
  • Vérifiez que vous ciblez la machine appropriée. Pour ce faire, ouvrez l’application runtime de l’ordinateur et sélectionnez Afficher la machine dans le portail pour vérifier qu’elle vous amène à la machine que vous ciblez dans votre exécution.

AttendedUserNotLoggedIn

Cette erreur se produit lorsque l’utilisateur spécifié dans la connexion n’est pas connecté à l’ordinateur cible.

Résolution

Pour résoudre le problème,

  • Connectez-vous sur l’ordinateur avec l’utilisateur utilisé pour l’exécution suivie et laissez la session active sur l’ordinateur.
  • Vérifiez que vous ciblez la machine appropriée. Pour ce faire, ouvrez l’application runtime de l’ordinateur et sélectionnez Afficher la machine dans le portail pour vérifier qu’elle vous amène à la machine que vous ciblez dans votre exécution.
  • Vérifiez les informations d’identification utilisées dans votre connexion et vérifiez qu’elles sont celles utilisées dans la session déverrouillée. Vous pouvez vérifier votre identité en tapant whoami n’importe quelle invite de commandes.

Note

Pour AttendedUserSessionNotActive ou AttendedUserNotLoggedIn erreurs, vérifiez que le compte qui exécute le service Power Automate (UIFlowService) dispose des autorisations Bureau à distance sur l’ordinateur. Par défaut, le service Power Automate s’exécute en tant que NT SERVICE\UIFlowService. Si vous ne l’avez pas modifié, vérifiez qu’il NT SERVICE\UIFlowService se trouve dans le groupe Utilisateurs bureau à distance. Pour ce faire, accédez à Démarrer>l’exécution, tapez usrmgr.msc, sélectionnez Groupes, double-cliquez sur le groupe Utilisateurs bureau à distance et vérifiez que le compte est inclus. S’il n’est pas inclus, incluez-le (cela nécessite des autorisations d’administrateur) et redémarrez l’ordinateur.

UIFlowAlreadyRunning

Lorsqu’un flux de bureau est déjà en cours d’exécution sur l’ordinateur, cette erreur peut se produire dans l’une des situations suivantes :

  • Vous exécutez un flux de bureau assisté ou sans assistance, et le nombre de sessions actives sur l’ordinateur a atteint sa limite.
  • Vous essayez d’ouvrir une session pour un utilisateur qui est déjà connecté.

Résolution

Pour résoudre le problème, attendez que les flux qui sont déjà en cours d’exécution soient terminés ou annulent l’exécution de leur flux cloud parent.

Autres codes d'erreur

Pour plus d’informations sur d’autres codes d’erreur qui peuvent se produire lors de l’exécution de flux de bureau et des étapes à atténuer, consultez Le code d’erreur se produit lors de l’exécution d’un flux de bureau assisté ou sans assistance.

Plus d’informations

Si le code de sous-erreur n’est pas fourni, vérifiez si :

  • L’ordinateur ou toutes les machines du groupe d’ordinateurs sont hors connexion.

    Démarrez l’ordinateur et vérifiez que Power Automate Desktop est correctement installé et peut communiquer avec Internet.

  • Le groupe d’ordinateurs est vide.

    Assurez-vous que votre groupe d’ordinateurs contient au moins un ordinateur avant de l’affecter à une exécution de flux de bureau.

  • L’ordinateur ou tous les ordinateurs du groupe d’ordinateurs sont occupés en permanence.

    Si les machines ne récupèrent pas le flux de bureau dans le temps, il est probable que les ressources d’ordinateur allouées ne soient pas suffisamment mises à l’échelle pour répondre à la demande de flux de travail. L’ajout d’ordinateurs supplémentaires peut aider à distribuer la charge de travail.

  • L’ordinateur ne peut pas être atteint en raison de problèmes de réseau (y compris le proxy ou le pare-feu).

    Collaborez avec votre administrateur informatique pour vous assurer que vos machines sont accessibles.

  • Le problème est temporaire.

    Essayez de modifier la stratégie de nouvelle tentative dans les paramètres des actions.

  • La machine ou toutes les machines du groupe d’ordinateurs ne peuvent pas se connecter au flux de bureau.

    Vérifiez que l’une des conditions suivantes est remplie :

    • Vous n’essayez pas d’exécuter un flux sans assistance sur un groupe dans lequel toutes les machines sont connectées.
    • Vous n’essayez pas d’exécuter un flux assisté sur un groupe où toutes les machines sont déconnectées.
  • La machine n’est plus utilisable.

    Ajoutez une nouvelle machine, puis mettez à jour les connexions de flux de bureau dans vos flux cloud pour utiliser la nouvelle machine.

Si vous disposez d’une sauvegarde des flux de bureau dans votre file d’attente d’exécution en raison de l’une des raisons ci-dessus, vous pouvez annuler en bloc vos exécutions de flux de bureau en annulant l’exécution du flux parent à l’aide de l’action Annuler l’exécution du flux parent sur la page Exécutions du flux de bureau. Une fois votre problème de machine résolu, vous pouvez redémarrer ces flux cloud.