Partager via


Le nombre d’enregistrements global ne correspond pas au contenu affiché dans une application pilotée par modèle

Cet article fournit des méthodes de dépannage pour un problème où le nombre d’enregistrements global ne correspond pas au contenu affiché dans une application basée sur un modèle Power Apps.

Symptômes

Un exemple classique de ce problème est que le nombre d’enregistrements affichés est inférieur au nombre affiché en bas de la page.

Cause

La raison la plus probable est que les données affichées dans la grille contiennent des enregistrements en double (par la valeur dans le champ principal). Le problème est dû à l’extraction des doublons d’enregistrements associés à partir de la même table.

Liste de contrôle pour la résolution des problèmes

  • Utilisez l’outil Power Apps Monitor pour vérifier le nombre total d’enregistrements.

    Capture d’écran montrant comment utiliser l’outil de surveillance pour obtenir des informations de page et d’enregistrement.

    Si le recordsCount nombre total d’enregistrements affichés en bas de la grille correspond, mais que les données de la grille contiennent moins d’enregistrements, il s’agit d’une indication forte que les données contiennent des enregistrements en double. Utilisez l’outil de surveillance pour obtenir la requête actuelle viewFetchXML .

    Capture d’écran montrant une requête fetchXML.

  • Le problème peut être résolu en ajoutant distinct="true" à la requête fetchXML. Pour plus d’informations, consultez Interroger des données à l’aide de FetchXml.

    Si l’ajout distinct="true" ne résout pas le problème, envisagez de modifier la requête pour éviter d’extraire des enregistrements en double. La colonne principale (champ) est également disponible à l’aide de l’outil Power Apps Monitor.

    Capture d’écran montrant la colonne principale dans une requête fetchXML.

Voir aussi

Résolution des problèmes de grille dans Power Apps