Partager via


« Actualiser tout » ne fonctionne pas après l’exportation des données d’application vers une feuille de calcul dynamique

Symptômes

Vous utilisez la commande Exporter vers Excel pour exporter des données d’application vers une feuille de calcul dynamique. Ensuite, vous ouvrez le fichier téléchargé et actualisez les données en sélectionnant Toutes les actualisations des données>. Dans ce cas, vous constatez que les données disparaissent et que le classeur apparaît vide. Vous pouvez recevoir le message d’erreur suivant :

Cette requête web n’a retourné aucune donnée. Pour modifier la requête, cliquez sur OK, cliquez sur la flèche dans la zone nom dans la barre de formule, cliquez sur le nom de la plage de données externe de la requête Web, cliquez avec le bouton droit sur la sélection, puis cliquez sur Modifier la requête.

Capture d’écran montrant la requête Web retournée aucune erreur de données qui se produit après l’actualisation des données d’application exportées.

Cause

Ce problème se produit lorsque les données auxquelles vous accédez sont protégées par mot de passe et que le fichier Excel ne peut pas envoyer de mots de passe à des sources de données externes.

Résolution

Pour corriger ce problème, vous devez modifier et enregistrer la requête Web.

  1. Dans le fichier Excel, sélectionnez Requêtes de données>et connexions.

    Capture d’écran montrant l’option Requêtes et connexions sous l’onglet Données.

  2. Le volet Requêtes et connexions s’ouvre à droite de la fenêtre. Sous l’onglet Connexions, cliquez avec le bouton droit sur la requête, puis sélectionnez Propriétés.

    Capture d’écran montrant les paramètres Propriétés d’une requête dans le volet Requêtes et connexions.

  3. La fenêtre Propriétés de connexion s’ouvre. Sous l’onglet Définition, sélectionnez Modifier la requête.

    Capture d’écran montrant le bouton Modifier la requête dans le Fenêtre Propriétés connexion.

  4. Si vous y êtes invité, entrez le nom d’utilisateur et le mot de passe. Saisissez le même nom d’utilisateur et le même mot de passe que ceux que vous utilisez pour vous connecter à votre application.

  5. Dans la fenêtre Modifier la requête web, sélectionnez Accéder. Un message d’erreur se produit :

    Impossible de terminer cette action

    Capture d’écran montrant le bouton Go dans la fenêtre Modifier la requête web.

  6. Fermez la fenêtre Modifier la requête Web.

  7. Cela doit résoudre le problème. Actualisez à nouveau les données dans la feuille de calcul en sélectionnant Tout actualiser les données>.

    Capture d’écran montrant comment actualiser les données de votre application dans Excel.

Si les étapes ci-dessus ne résolvent pas le problème, procédez comme suit :

  1. Entrez le lien suivant dans la barre d’adresse de la fenêtre Modifier la requête web pour accéder à la page Paramètres avancés dans Microsoft Dynamics 365 Customer Engagement. N’oubliez pas de remplacer OrgURL l’URL de votre organisation.

    https://OrgURL/main.aspx?settingsonly=true

  2. Déconnectez-vous à l’aide du lien d’option de profil en haut à droite, puis reconnectez-vous à l’aide de l’identité appropriée.

  3. Une fois connecté, fermez la fenêtre Modifier la requête web, puis, dans le fichier Excel, sélectionnez Actualiser tous les données>. Les données seront actualisées comme prévu.

Voir aussi

Exporter des données vers une feuille de calcul dynamique Excel