Partager via


Certaines colonnes ne contiennent pas de données dans une application pilotée par modèle

Cet article fournit des étapes de dépannage pour un problème où certaines colonnes ne contiennent pas de données dans une application pilotée par modèle dans Microsoft Power Apps.

Symptômes

Vous pouvez trouver des données qui ne s’affichent pas dans certaines colonnes d’une application basée sur un modèle Power Apps.

Cause

Ce problème est souvent dû aux différences entre la requête fetchXML (la requête pour les données) et la dispositionXML (définitions de colonnes), ce qui peut être dû au code personnalisé qui modifie incorrectement la requête. Avant de résoudre le problème, suivez les étapes décrites dans Étapes à effectuer avant de commencer la résolution des problèmes.

Étape de dépannage

Tout d’abord, vous devez vous assurer que le problème n’est pas lié aux autorisations insuffisantes. Le moyen le plus simple de vérifier cela consiste à accéder à la page en tant qu’utilisateur disposant de privilèges d’administration complets. L’outil Power Apps Monitor peut également être utilisé pour vous assurer que les données de colonne sont lisibles.

Capture d’écran de l’attribut isreadable dans l’outil Power Apps Monitor.

Si le problème n’est pas lié à des autorisations insuffisantes, utilisez l’outil Power Apps Monitor pour vérifier la définition de requête et de colonnes, comme illustré dans la capture d’écran suivante.

Capture d’écran de la section viewFields et de la requête viewFetchXML dans l’outil Power Apps Monitor.

Vérifiez que toutes les colonnes répertoriées dans la viewFields section sont présentes dans la viewFetchXML requête et que les colonnes respectives ne sont pas marquées comme hidden.

Le problème peut également être dû à une vue endommagée. La republier et la republier d’une telle vue peuvent aider à résoudre le problème.

Voir aussi

Résolution des problèmes de grille dans Power Apps