L’erreur « Attribut PrimaryName introuvable pour l’entité » se produit lors de l’importation de la solution
Cet article fournit une solution de contournement pour une erreur qui se produit lorsque vous importez une solution dans Power Apps.
S’applique à : Power Platform, Solutions
Symptômes
Lorsque vous importez une solution, vous recevez le message d’erreur suivant :
L’attribut PrimaryName est introuvable pour l’entité
Cause
Cette erreur se produit lorsque l’attribut de nom principal d’une table n’est pas inclus dans le fichier .xml de la solution.
Solution de contournement
Pour contourner ce problème, effectuez les étapes suivantes :
- Supprimez la table de la solution dans l’environnement source.
- Ajoutez la table et toutes les ressources à l’environnement source pour vous assurer que les métadonnées nécessaires sont incluses.
- Exportez la solution et importez-la à nouveau dans l’environnement cible.