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La synchronisation d’annuaires avec l’ID Microsoft Entra s’arrête ou vous êtes averti que la synchronisation n’a pas été inscrite dans plus d’un jour

Cet article décrit un problème de performances dans Azure Active Directory Sync Tool. L’outil arrête la synchronisation ou signale que la synchronisation n’a pas été exécutée dans plus de 24 heures.

Version du produit d’origine : Microsoft Entra ID, Microsoft Intune, Sauvegarde Azure, Office 365 Identity Management
Numéro de base de connaissances d’origine : 2882421

Note

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Symptômes

Vous rencontrez l’un des symptômes suivants :

  • L’outil de synchronisation Microsoft Azure Active Directory arrête la synchronisation.
  • Vous recevez des messages électroniques indiquant que l’ID Microsoft Entra n’a pas inscrit une tentative de synchronisation au cours des 24 dernières heures.
  • Dans l’outil MIISClient.exe , vous recevez un message « Stop-Server-Down » ou un message « Stopped-Extension-DLL-Exception ».
  • Vous ne pouvez pas démarrer un ou plusieurs des services de synchronisation d’annuaires.

Note

Par défaut, la synchronisation d’annuaires s’exécute toutes les trois heures.

Cause

Ce problème peut se produire si une ou plusieurs des conditions suivantes sont remplies :

  • Le compte professionnel ou scolaire qui a été utilisé dans l’Assistant de configuration pour définir la synchronisation d’annuaires présente l’un des problèmes suivants :

    • Le compte a été supprimé.
    • Le compte a été désactivé.
    • Le mot de passe du compte a expiré.
  • Le compte d’ouverture de session pour un ou plusieurs services de synchronisation d’annuaires présente l’un des problèmes suivants :

    • Le compte a été supprimé.
    • Le compte a été désactivé.
    • Le mot de passe du compte a expiré.

    Note

    Le compte d’ouverture de session du service de synchronisation d’annuaires est automatiquement configuré et ne doit pas être modifié.

  • Le compte d’administrateur utilisé pour la synchronisation d’annuaires a été modifié.

  • Vous rencontrez des problèmes de connexion réseau.

  • Les services de synchronisation d’annuaires sont arrêtés.

Résolution

Méthode 1 : Vérifier manuellement que le service est démarré et que le compte d’administrateur peut se connecter

  1. Sélectionnez Démarrer, sélectionner Exécuter, taper Services.msc, puis OK.

  2. Recherchez le service de l’appliance microsoft Entra Synchronization, puis vérifiez si le service est démarré. Si le service n’est pas démarré, cliquez dessus avec le bouton droit, puis sélectionnez Démarrer.

    • Si vous utilisez l’outil Azure Active Directory Sync, recherchez le service Azure Active Directory Sync.
    • Si vous utilisez Microsoft Entra Connect, recherchez Microsoft Azure AD Sync.
  3. Vérifiez que le compte d’administrateur utilisé pour la synchronisation d’annuaires existe toujours. Vérifiez que le compte est autorisé à se connecter. Si le compte existe toujours, réinitialisez le mot de passe, puis vérifiez que vous pouvez vous connecter. Si vous y êtes invité, modifiez le mot de passe.

    Si vous ne connaissez pas le compte d’administrateur général utilisé pour configurer la synchronisation d’annuaires, procédez comme suit sur le serveur sur lequel vous avez installé l’appliance de synchronisation d’annuaires :

    1. Accédez à %ProgramFiles%\Microsoft Azure AD Sync\UIShell\, puis exécutez Miisclient.exe.

      Note

      Si vous utilisez Microsoft Entra Connect ou le service de synchronisation Azure Active Directory, sélectionnez Démarrer, puis recherchez et ouvrez le service de synchronisation.

    2. Sélectionnez Connecteurs, puis double-cliquez sur le connecteur Microsoft Entra.

    3. Sélectionnez Connectivité.

    4. Prenez note de la valeur UserName. Il s’agit du compte d’administrateur général utilisé pour configurer la synchronisation d’annuaires.

  4. Sur le serveur de synchronisation d’annuaires, exécutez l’Assistant Configuration de l’appliance de synchronisation Microsoft Entra. Tapez le nouveau mot de passe du compte d’administrateur utilisé pour la synchronisation d’annuaires, puis suivez les étapes restantes de l’Assistant.

  5. Lorsque vous y êtes invité, activez la case à cocher Forcer la synchronisation d’annuaires.

Méthode 2 : Résoudre le problème lié au compte d’ouverture de session pour le service de synchronisation d’annuaires

  1. Sélectionnez Démarrer, sélectionner Exécuter, taper Services.msc, puis OK.

  2. Recherchez le service de l’appliance de synchronisation Microsoft Entra :

    • Si vous utilisez l’outil Azure Active Directory Sync, recherchez le service Azure Active Directory Sync.
    • Si vous utilisez Microsoft Entra Connect, recherchez Microsoft Azure AD Sync. Cliquez avec le bouton droit sur le service, puis sélectionnez Propriétés. Sous l’onglet Connexion , notez le nom du compte répertorié.

    Note

    La reconfiguration des services de synchronisation d’annuaires pour se connecter en tant que compte système local n’est pas prise en charge et peut entraîner des problèmes.

  3. Sur un contrôleur de domaine ou un ordinateur sur lequel les outils d’administration sont installés, ouvrez Utilisateurs et ordinateurs Active Directory (Dsa.msc), cliquez avec le bouton droit sur le nom de domaine, puis sélectionnez Rechercher. Tapez le nom du compte que vous avez noté à l’étape 2, puis sélectionnez Rechercher maintenant.

    • Si vous trouvez le compte, accédez à l’étape 4.
    • Si vous ne trouvez pas le compte, il a peut-être été supprimé. Pour plus d’informations sur la restauration de ce compte, consultez le Guide pas à pas de la Corbeille Active Directory. Si vous ne pouvez pas restaurer le compte, vous devez désinstaller, puis réinstaller le client de synchronisation d’annuaires.
  4. Cliquez avec le bouton droit sur le compte, puis sélectionnez Propriétés. Sous l’onglet Compte , sous Options de compte, procédez comme suit :

    1. Vérifiez que la case à cocher Mot de passe n’expire jamais est activée.
    2. Vérifiez que la case à cocher Compte est désactivée . Ensuite, effectuez l’une des actions suivantes :
    • Si la case à cocher Compte est désactivée , désactivez-la pour activer le compte. Ensuite, redémarrez le service d’appliance de synchronisation Microsoft Entra. Pour ce faire, sélectionnez Démarrer, sélectionnez Exécuter, tapez Services.msc, puis ok. Recherchez le service, cliquez dessus avec le bouton droit, puis sélectionnez Redémarrer.
      • Si vous utilisez l’outil Azure Active Directory Sync, recherchez le service Azure Active Directory Sync.
      • Si vous utilisez Microsoft Entra Connect, recherchez Microsoft Azure AD Sync.
    • Si la case à cocher Compte est désactivée est déjà désactivée , accédez à l’étape 5.
  5. Si la case à cocher Compte est déjà désactivée , il est possible que le mot de passe du compte ait été modifié manuellement. Pour définir un nouveau mot de passe, ouvrez Utilisateurs et ordinateurs Active Directory, recherchez et cliquez avec le bouton droit sur le compte, puis sélectionnez Réinitialiser le mot de passe pour réinitialiser le mot de passe. Notez le mot de passe que vous définissez, car vous devrez l’utiliser à l’étape suivante.

  6. Définissez le mot de passe sur le compte d’ouverture de session pour les services de synchronisation d’annuaires :

    1. Sélectionnez Démarrer, sélectionner Exécuter, taper Services.msc, puis OK.

    2. Définissez le mot de passe pour les services suivants, en fonction du client que vous utilisez. Pour ce faire, cliquez avec le bouton droit sur le service approprié, sélectionnez Propriétés, sélectionnez l’onglet Connexion , puis tapez le mot de passe.

      Client de synchronisation Microsoft Entra Microsoft Entra Connect

      Service de synchronisation Forefront Identity Manager
      SQL Server (MOSONLINE) (le cas échéant)
      Service de synchronisation Azure Active Directory

      Azure AD Sync
    3. Démarrez le service ou les services pour lesquels vous définissez le nouveau mot de passe.

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