L’affichage n’est pas disponible lors de l’ouverture d’un e-mail dans Microsoft Dynamics 365 App pour Outlook
Cet article fournit une résolution pour résoudre l’erreur La vue n’est pas disponible qui se produit lorsque vous essayez d’ouvrir un e-mail dans Microsoft Dynamics 365 App pour Outlook.
S’applique à : Microsoft Dynamics CRM Online
Numéro de base de connaissances d’origine : 4338690
Symptômes
Lorsque vous ouvrez un e-mail dans Microsoft Dynamics 365 App pour Outlook, vous voyez l’erreur suivante :
« La vue n’est pas disponible. Veuillez contacter votre administrateur système. »
Cause
Cette erreur peut apparaître si vous avez désactivé l’une des vues utilisées par l’application Microsoft Dynamics 365 pour Outlook. L’application Microsoft Dynamics 365 pour Outlook utilise un formulaire spécial pour afficher les informations de prospect (App for Outlook Lead Quick View) ou Contact (App for Outlook Contact Quick View). Chacun de ces formulaires inclut des listes qui référencent des vues spécifiques. Si l’une de ces vues est désactivée, vous pouvez voir qu’une vue n’est pas disponible .
Résolution
Vérifiez que les vues utilisées par le formulaire App for Outlook Lead Quick View et App for Outlook Contact Quick View ne sont pas désactivées. Lorsque vous affichez un e-mail dans l’application Microsoft Dynamics 365 pour Outlook, le formulaire utilisé dépend si l’e-mail provient d’un prospect ou d’un contact. Si vous voyez uniquement cette erreur lorsqu’un e-mail provient d’un contact, vous devrez peut-être corriger uniquement les vues utilisées par le formulaire de contact. Si vous ne voyez que l’erreur lorsque l’e-mail provient d’un prospect, vous devrez peut-être corriger uniquement les vues utilisées par le formulaire de prospect. Dans l’exemple ci-dessous, nous allons vérifier que les vues par défaut utilisées par le formulaire App for Outlook Contact Quick View sont activées. Vous pouvez utiliser des étapes similaires pour le formulaire App for Outlook Lead Quick View qui se trouve sous l’entité Lead au lieu de l’entité Contact :
- En tant qu’utilisateur disposant du rôle de sécurité Administrateur système ou Personnalisateur système, ouvrez l’application web Microsoft Dynamics 365.
- Accédez à Paramètres , puis sélectionnez Personnalisations.
- Sélectionnez Personnaliser le système. La boîte de dialogue Solution par défaut s’ouvre.
- Sélectionnez Entités, sélectionnez Contact, puis formulaires.
- Ouvrez le formulaire App for Outlook Contact Quick View . Par défaut, ce formulaire inclut deux listes pour les activités, une liste pour les opportunités et une liste pour les cas. Les tableaux ci-dessous affichent les noms par défaut des listes ainsi que l’affichage par défaut utilisé pour la liste.
- Vous pouvez utiliser ces tables comme référence pour réactiver la vue par défaut.
- Dans cet exemple, nous allons examiner les deux premières listes provenant de l’entité Activity. Vous pouvez répéter les mêmes étapes pour les autres entités mentionnées.
- Revenez à la boîte de dialogue Solution par défaut, sélectionnez Activité, puis sélectionnez Affichages.
- Sélectionnez la liste déroulante Affichage et sélectionnez Affichages publics inactifs.
- Vérifiez que les vues Activité suivante et Dernière activité n’apparaissent pas dans la liste Affichages publics inactifs. Si l’une de ces vues est désactivée, sélectionnez-les, puis sélectionnez Activer.
- Après avoir utilisé les mêmes étapes pour vérifier que les autres vues sont actives, sélectionnez Publier toutes les personnalisations.
- Vous devrez peut-être fermer et rouvrir Outlook et éventuellement effacer votre cache de navigateur.
Vue rapide de l’application pour les contacts Outlook
Nom de la liste | Vue par défaut | Entité |
---|---|---|
Activité suivante | Activité suivante | Activité |
Dernière activité | Dernière activité | Activité |
Opportunités récentes | Opportunités récentes pour le formulaire centré sur l’interaction | Opportunité |
Cas récents | Mes incidents actifs | Cas |
Formulaire App for Outlook Lead Quick View
Nom de la liste | Vue par défaut | Entité |
---|---|---|
Activité suivante | Activité suivante | Activité |
Dernière activité | Dernière activité | Activité |
Parties prenantes | Toutes les parties prenantes | Connexion |
Concurrents | Tous les concurrents (résumé) | Concurrent |
Note
Si vous souhaitez modifier les vues utilisées par ces formulaires au lieu d’activer les vues par défaut, vous pouvez ouvrir les propriétés de la section de liste du formulaire pour modifier l’affichage sélectionné. Si vous avez désactivé l’une des vues par défaut, vous ne pourrez pas réellement la voir référencée par la liste même si elle fait actuellement référence à cette vue par défaut. Au lieu de cela, il affiche un autre nom d’affichage actif. Vous devrez peut-être d’abord le remplacer par un autre affichage, puis le remplacer par l’affichage que vous souhaitez que la modification prenne effet.
Microsoft est conscient d’un problème où vous pouvez rencontrer une erreur lors de la tentative de modification des vues. Vous pouvez modifier l’activité suivante et les dernières vues d’activité, mais lorsque vous essayez de modifier les autres affichages, vous rencontrez une erreur (une erreur s’est produite. Revenez à la page d’accueil et réessayez). Microsoft examine une solution de protection à ce problème.