Partager via


Le fichier d’importation est trop volumineux pour charger une erreur se produit lors de l’importation d’une solution dans Microsoft Dynamics 365

Cet article fournit une solution à une erreur qui se produit lorsque vous essayez d’importer une solution dans Microsoft Dynamics 365.

S’applique à : Microsoft Dynamics 365
Numéro de base de connaissances d’origine : 4462491

Symptômes

Lorsque vous tentez d’importer une solution dans Dynamics 365, l’importation échoue et le message suivant s’affiche :

« Le fichier d’importation est trop volumineux à charger.
Code d’erreur 80040375 »

Cause

Bien que le message d’erreur indique un problème avec la taille maximale de la solution à importer, un autre problème tel qu’une erreur SQL peut être la cause.

Résolution

Sélectionnez le bouton Télécharger le fichier journal pour afficher un message plus détaillé. Vous pouvez voir des détails tels que le message suivant :

Échec de l’importation. Pour plus d’informations, consultez les messages d’erreur associés. : les noms de colonnes System.Data.SqlClient.SqlException (0x80131904) dans chaque table doivent être uniques. Le nom de colonne '<nom de colonne>' dans la table '<entity/table name>' est spécifié plusieurs fois.

L’exemple de message ci-dessus est une erreur SQL qui peut se produire si vous essayez d’importer un champ qui existe déjà dans cette entité.

Exemple : si vous aviez créé un champ personnalisé dans l’organisation avec un nom de schéma appelé new_field1 sur l’entité Compte. Vous essayez maintenant d’importer une solution qui contient un champ portant ce même nom de schéma sur l’entité Compte. SQL n’autorise pas plusieurs colonnes portant le même nom dans la même table afin qu’elle provoque l’échec de l’importation. Dans l’environnement cible, vous avez peut-être déjà un champ portant le même nom de schéma, mais une casse différente telle que new_Field1 et le champ de la solution que vous importez est new_field1. Si le champ portant le même nom n’est pas nécessaire dans l’environnement cible, supprimez-le, puis réessayez d’importer.

Si l’erreur persiste et que vous ne pouvez pas résoudre le problème à l’aide des détails du fichier journal, contactez Support Microsoft pour obtenir de l’aide. Vous pouvez également utiliser les informations du fichier journal pour rechercher des solutions potentielles dans les communautés Dynamics 365.