Partager via


L’importation de la solution échoue en raison de composants manquants

Cet article fournit une résolution pour l’importation de l’erreur d’échec de la solution [nom de la solution] qui peut se produire lorsque vous essayez d’importer une solution dans Microsoft Dynamics 365.

S’applique à : Microsoft Dynamics 365
Numéro de base de connaissances d’origine : 4346030

Symptômes

Lorsque vous tentez d’importer une solution dans Microsoft Dynamics 365, l’importation échoue avec le message suivant :

L’importation de la solution [nom de la solution] a échoué. Les composants suivants sont manquants dans votre système et ne sont pas inclus dans la solution. Importez les solutions managées qui contiennent ces composants ([nom de la solution manquante] ([version de la solution])), puis réessayez d’importer la solution.

Vous pouvez également voir une référence au code d’erreur 8004801d.

Cause

Cette erreur se produit si vous essayez d’importer une solution qui dépend d’autres composants qui ne se trouvent pas dans votre organisation Microsoft Dynamics 365.

Exemple : vous disposez d’un environnement de développement dans lequel vous avez créé une solution (Solution A) qui contient une entité personnalisée (Widget). Vous avez créé une autre solution (Solution B) qui dépend d’un composant de la solution A (par exemple, ajouté un nouveau champ à l’entité Widget). Si vous essayez d’importer la solution B dans une autre organisation (par exemple, votre organisation de production) qui n’a pas déjà installé la solution A, vous rencontrerez cette erreur.

Résolution

Passez en revue les détails du composant manquants affichés dans la boîte de dialogue d’importation. S’il existe d’autres solutions répertoriées qui ne sont pas déjà importées dans l’organisation où vous essayez d’importer cette solution, importez d’abord ces solutions avant d’essayer d’importer cette solution.

Exemple : en suivant l’exemple de la section Cause ci-dessus, vous pouvez voir que la liste des composants manquants affiche une ou plusieurs lignes où la colonne Solution managée fait référence à la solution A. Cela indique que vous devrez importer la version mentionnée de la solution A avant de pouvoir importer correctement la solution B.

Plus d’informations

Si le message d’erreur fait référence à une solution Microsoft, reportez-vous à la liste suivante de solutions et où elles sont trouvées si elles ne sont pas installées dans l’organisation cible :

LinkedIn Sales Navigator pour Dynamics 365

Noms de solution :

  • LinkedInSalesNavigatorControlsForUnifiedClient

  • LinkedIn

  • msdyn_LinkedInSalesNavigatorAnchor

    Note

    Si vous souhaitez désinstaller ces solutions, elles doivent être désinstallées dans l’ordre de la liste ci-dessus.