Partager via


Le code d’erreur 80040203 (argument non valide) se produit lorsque vous essayez d’importer une solution dans Microsoft Dynamics 365

Cet article fournit une solution à une erreur qui se produit lorsque vous essayez d’importer une solution dans Microsoft Dynamics 365.

S’applique à : Microsoft Dynamics 365 Customer Engagement Online
Numéro de la base de connaissances d’origine : 4514229

Symptômes

Lorsque vous essayez d’importer une solution dans Dynamics 365, vous recevez le message d’erreur suivant :

« L’importation de la solution : <Le nom> de la solution a échoué.
Code d’erreur 80040203."

Note

Ce code d’erreur est documenté dans les codes d’erreur du service Web avec les informations suivantes :

Nom : InvalidArgument
Hex : 80040203
Nombre : -2147220989
Argument non valide.

Cause

Cette erreur peut être due à plusieurs raisons. Si votre boîte de dialogue d’erreur fait référence au type d’objet suivant, passez en revue le reste de cet article pour obtenir une solution potentielle :

Type : Relation
Nom : bpf_<entity>_<publisher>_<BPF Name>

Téléchargez le fichier journal qui, lorsqu’il est ouvert sur la page Composants, affiche :

ItemType : Relation d’entité
Nom : bpf_<entity>_<publisher>_<BPF Name>
ErrorCode : 0x80040203
ErrorText : Nom d’affichage de l’attribut pour l’ID : <GUID>, objectcolumn : DisplayName et labelTypeCode : Attribut non spécifié

Le nom de la relation d’entité est la concaténation d’une entité et d’un flux de processus métier (BPF). L’entité a été précédemment supprimée d’une phase BPF et remplacée par une autre entité, puis le BPF a été mis à jour tout en restant activé. L’entité a été supprimée du BPF, mais la relation existe toujours dans le schéma. Il est donc exporté avec la solution à partir de la source. Cette relation provoque l’affichage de l’erreur.

Résolution

Microsoft est conscient de ce problème et travaille sur une modification pour supprimer cette relation après une suppression, puis mise à jour.

Il existe deux solutions de contournement pour ce problème :

Option 1 - Mettre à jour le fichier de solution

Si vous devez importer la solution et ne pouvez pas recréer le package de solution, supprimez la relation de la solution.

  1. Décompressez la solution.

  2. Modifiez le customization.xml.

  3. Recherchez la relation mentionnée dans l’erreur : bpf_<entity>_<publisher>_<BPF Name>

  4. Supprimez tout le code XML pour EntityRelationship :

    <EntityRelationship Name="bpf_<entity>_<publisher>_<BPF Name>">
    ...
    </EntityRelationship>
    
  5. Enregistrez le fichier.

  6. Compressez l’intégralité du répertoire.

  7. Réimportez la solution.

Option 2 : Supprimer la relation de la source et recréer votre solution

Il s’agit d’une résolution à long terme et résout le problème pour l’exportation suivante de la solution.

  1. Ouvrez l’organisation source.

  2. Sélectionner les personnalisations des / paramètres / personnaliser le système

  3. Sélectionnez l’entité dans la relation :

    bpf_<entity>_<publisher>_<BPF Name>
    
  4. Développez 1 :N Relations.

  5. Recherchez la relation :

    bpf_<entity>_<publisher>_<BPF Name>
    
  6. Sélectionnez et supprimez la relation.

  7. Publiez toutes les personnalisations.

  8. Exportez la solution et importez-la dans la cible.