Erreur 0x800705B4 lors de l’activation d’une machine virtuelle Azure Windows
S’applique à : ✔️ Machine virtuelles Windows
Cet article fournit une solution à l’erreur 0x800705B4 qui se produit lorsque vous essayez d’activer une machine virtuelle Windows Azure.
Symptômes
Lorsque vous essayez d’activer votre ordinateur virtuel Windows Azure, vous recevez une erreur 0x800705B4 :
Activation de Windows
Un problème s’est produit lorsque Windows a essayé d’activer. Code d’erreur 0x800705B4.
Pour une résolution possible, cliquez sur Plus d’informations.
Contactez votre administrateur système ou le service de support technique pour obtenir de l’aide.
Elle peut également être affichée en tant qu’erreur Security-SPP (ID d’événement 8196) dans le journal des applications.
Cause
Cette erreur indique un délai d’attente arrivé à expiration. Cela peut être dû à des problèmes de connectivité réseau ou de résolution DNS (Domain Name System).
Étapes de dépannage
Procédez comme suit pour vérifier les problèmes de connectivité réseau, puis réessayez l’activation.
Vérifier la connectivité entre la machine virtuelle et le service Azure KMS
Vérifiez que la machine virtuelle est configurée pour utiliser le serveur Azure Service de gestion de clés s (KMS) approprié. Pour ce faire, exécutez la commande suivante :
Invoke-Expression "$env:windir\system32\cscript.exe $env:windir\system32\slmgr.vbs /skms azkms.core.windows.net:1688"
Cette commande doit retourner la sortie suivante :
Le nom de machine du service de gestion de clés a été configuré sur
azkms.core.windows.net:1688
avec succès.Vérifiez que le trafic réseau sortant vers le point de terminaison KMS sur le port 1688 n’est pas bloqué par le pare-feu dans la machine virtuelle. Pour ce faire, exécutez l’applet de commande PowerShell Test-NetConnection ou l’outil PsPing .
Vérifiez en exécutant
Test-NetConnection
:Test-NetConnection azkms.core.windows.net -port 1688
Si la connectivité est autorisée, vous pouvez constater
TcpTestSucceeded: True
dans la sortie.Vérification à l’aide de PsPing. Basculez vers le dossier où vous avez extrait l’archive
Pstools.zip
, puis exécutez la commande suivante :.\psping.exe azkms.core.windows.net:1688
Sur la deuxième à la dernière ligne de la sortie, vérifiez que le texte suivant s’affiche :
Sent = 4, Received = 4, Lost = 0 (0% loss)
Si
Lost
elle est supérieure à 0 (zéro), la machine virtuelle n’a pas de connectivité au serveur KMS. Dans ce cas, si la machine virtuelle se trouve dans un réseau virtuel et a spécifié un serveur DNS personnalisé, vous devez vous assurer que le serveur DNS est en mesure de résoudreazkms.core.windows.net
. Sinon, passez à un serveur DNS capable de résoudreazkms.core.windows.net
.Note
Si vous supprimez l’ensemble des serveurs DNS d’un réseau virtuel, les machines virtuelles utiliseront le service DNS interne d’Azure. Ce service peut résoudre
azkms.core.windows.net
.
Vérifiez à l’aide du tronçon suivant d’Azure Network Watcher que le type de tronçon suivant de la machine virtuelle en question vers les adresses IP
20.118.99.224
de destination et40.83.235.53
(pourazkms.core.windows.net
) ou l’adresse IP du point de terminaison KMS approprié qui s’applique à votre région est Internet.Si le résultat est VirtualAppliance ou VirtualNetworkGateway, un itinéraire par défaut existe probablement. Contactez votre administrateur réseau et collaborez avec lui pour déterminer la marche à suivre. Il peut s’agir d’une route personnalisée si cette solution est conforme aux stratégies de votre organisation.
Après avoir vérifié la réussite de la connectivité,
azkms.core.windows.net
exécutez la commande suivante à une invite Windows PowerShell avec élévation de privilèges. Cette commande tente plusieurs fois l’activation :1..12 | ForEach-Object { Invoke-Expression "$env:windir\system32\cscript.exe $env:windir\system32\slmgr.vbs /ato" ; start-sleep 5 }
Une activation réussie renvoie des informations qui ressemblent à ceci :
Activation de Windows(R), édition ServerDatacenter (12345678-1234-1234-1234-12345678)... Produit activé avec succès.
Contactez-nous pour obtenir de l’aide
Pour toute demande ou assistance, créez une demande de support ou posez une question au support de la communauté Azure. Vous pouvez également soumettre des commentaires sur les produits à la communauté de commentaires Azure.