Partager via


Résoudre les problèmes liés au code d’erreur « Quotaexceeded »

Cet article explique comment identifier et résoudre l’erreur « QuotaExceededed » qui se produit lorsque vous essayez de mettre à niveau un cluster Azure Kubernetes Service (AKS).

Voici un exemple de message d’erreur :

L’opération entraîne un dépassement de cœurs des limites de quota. Maximum autorisé : X, Actuel en cours d’utilisation : X, Supplémentaire demandé : X

Prerequisites

Cet article nécessite Azure CLI version 2.0.65 ou une version ultérieure. Pour rechercher le numéro de version, exécutez az --version. Si vous devez installer ou mettre à niveau Azure CLI, consultez Comment installer Azure CLI.

Pour plus d’informations sur le processus de mise à niveau, consultez la section « Mettre à niveau un cluster AKS » dans Mettre à niveau un cluster Azure Kubernetes Service (AKS).

Symptômes

Une mise à niveau du cluster AKS échoue et vous recevez un message d’erreur « QuotaExceeded ».

Cause

Le problème se produit si le quota est atteint. Votre abonnement n’a pas de ressources disponibles requises pour la mise à niveau.

Solution

Pour augmenter la limite ou le quota de votre abonnement, accédez au Portail Azure et déposez un ticket de support des limites de service et d’abonnement (quotas). Dans ce cas, vous devez envoyer un ticket de support pour augmenter le quota de cœurs de calcul.

Contactez-nous pour obtenir de l’aide

Pour toute demande ou assistance, créez une demande de support ou posez une question au support de la communauté Azure. Vous pouvez également soumettre des commentaires sur les produits à la communauté de commentaires Azure.