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Une erreur s’affiche dans un rapport de synchronisation d’annuaires : cette entreprise a dépassé le nombre d’objets qui peuvent être synchronisés

Cet article explique comment augmenter le quota de service Active Directory Directory pour la synchronisation d’annuaires dans un environnement Office 365, Azure ou Microsoft Intune.

Version du produit d’origine : Services cloud (rôles web/rôles de travail), ID Microsoft Entra, Microsoft Intune, Sauvegarde Azure, Office 365 User and Domain Management
Numéro de base de connaissances d’origine : 2812409

Symptômes

Vous recevez un e-mail de MSOnlineServicesTeam@MicrosoftOnline.com qui contient le message d’erreur suivant :

Erreur 016 : La synchronisation a été arrêtée. Cette société a dépassé le nombre d’objets pouvant être synchronisés. Contactez le support technique de Microsoft Online Services.

Note

Cet article peut également être utilisé si vous souhaitez simplement demander d’augmenter le quota de service d’annuaire si vous envisagez d’avoir plus que le nombre autorisé d’objets dans un service cloud Microsoft tel qu’Office 365, Azure ou Microsoft Intune, et que vous n’utilisez pas la synchronisation Active Directory. Le quota de service d’annuaire actuel dans l’ID Microsoft Entra est de 50 000 objets.

Cause

Ce problème se produit car le nombre d’objets que vous avez créés dans votre ID Microsoft Entra dépasse la limite de votre service d’annuaire. Microsoft Entra ID limite le nombre d’objets qui peuvent être créés par chaque organisation. Les groupes, les contacts et les objets utilisateur de votre organisation Microsoft Entra sont comptabilisés dans l’utilisation de l’annuaire de votre organisation.

Votre quota de service d’annuaire par défaut est calculé conformément aux indications suivantes :

  • Si vous n’avez pas de domaines vérifiés, le quota de service d’annuaire actuel dans l’ID Microsoft Entra est de 50 000 objets.

    1. Si votre organisation a été créée avant le 5 octobre 2011, votre quota de service d’annuaire par défaut est de 10 000 objets.
    2. Si votre organisation a été créée après le 5 octobre 2011 et avant mai 2012, votre quota de service d’annuaire par défaut est de 20 000 objets.
    3. Si votre organisation a été créée après mai 2012, votre quota de service d’annuaire par défaut est de 50 000 objets.
  • Si vous avez au moins un domaine vérifié, le quota de service d’annuaire par défaut dans Microsoft Entra ID est de 300 000 objets.

Résolution

Quand le nombre de groupes, de contacts et d’objets utilisateur de votre instance Active Directory locale dépasse votre quota de service d’annuaire, vous pouvez demander une augmentation de la limite de quota de service d’annuaire pour votre entreprise. Cette augmentation vous permet de synchroniser plus d’objets que la limite par défaut actuelle quand vous utilisez la synchronisation d’annuaire.

Pour continuer à créer des objets dans votre organisation, vous devez soit ajouter un domaine, soit demander une augmentation de votre quota de service d’annuaire. Pour ce faire, utilisez les méthodes suivantes.

Méthode 1

Si vous n’avez pas de domaine vérifié, vous devez ajouter un domaine pour augmenter votre limite de quota à 300 000 objets. Pour plus d’informations, consultez Ajouter votre domaine.

Méthode 2

Si vous avez plus de 300 000 objets dans votre service d’annuaire Active Directory local, pour augmenter le nombre d’objets pouvant être synchronisés au-delà de 300 000, contactez Support Microsoft.

Plus d’informations

Un quota de service d’annuaire est implémenté à l’aide du service cloud comme méthode pour limiter le nombre maximal d’objets pouvant être créés et détenus par un seul principal de sécurité. Tous les objets qui sont synchronisés à l’aide de la synchronisation d’annuaire avec une entreprise ont la valeur de créateur/propriétaire définie sur le groupe d’administrateurs par défaut de cette entreprise. Par exemple, le groupe administrateurs est défini comme suit : admins@contoso1.microsoftonline.com. Par conséquent, cette configuration empêche les utilisateurs de créer un nombre illimité d’objets à l’aide de la synchronisation d’annuaire. Si une entreprise a besoin, à juste titre, de synchroniser plus d’annuaires que la limite de quota de service d’annuaire, soumettez une demande de service au support technique.

Forum aux questions

Question 1 : Les objets qui ont été ajoutés manuellement via le portail de service cloud ou via l’API de service cloud, comme Exchange Online PowerShell, comptent-ils par rapport au quota de mon entreprise en ligne ?

Réponse 1 : Oui.

Question 2 : Les objets supprimés sont-ils comptabilisés par rapport au quota de mon entreprise en ligne ?

Réponse 2 : Oui. Quand un client de service cloud supprime un objet d’une entreprise en ligne, l’objet supprimé est placé dans un conteneur d’objets supprimés dans le service d’annuaire. L’objet reste dans le conteneur d’objets supprimés jusqu’à l’expiration de la durée de vie de temporisation. L’expiration est actuellement définie sur 30 jours.

Par exemple, considérez le scénario suivant. Une entreprise en ligne évalue un service cloud à l’aide d’un environnement Active Directory local hors production. L’organisation de service cloud a été créée avant le 5 octobre 2011, et la limite de synchronisation par défaut est de 10 000 objets. L’entreprise effectue une synchronisation en bloc de 8 000 objets groupe et objets contact à l’aide de l’outil Directory Sync. Par la suite, l’entreprise en ligne décide d’effectuer les opérations suivantes :

  1. Supprimez ces objets de groupe et contactez les objets de l’environnement Active Directory DS local de l’entreprise.
  2. Ajoutez 8 000 objets utilisateur à son environnement Active Directory DS local.
  3. Synchronisez les mises à jour de sa société en ligne.

Les 8 000 objets groupe et objets contact sont déplacés vers le conteneur d’objets supprimés dans le service d’annuaire. Et ces objets continuent à consommer jusqu’à 25 % du quota d’entreprise en ligne jusqu’à ce qu’ils soient définitivement supprimés après la période de temporisation de 30 jours. (Ce pourcentage est égal à 2 000 objets, ou 8 000 × 25 %.) Par conséquent, après la synchronisation des 5 000 nouveaux objets utilisateur, l’entreprise en ligne consomme 10 000 objets de son quota Active Directory disponible : 2 000 des objets supprimés + 8 000 des nouveaux objets utilisateur. Pendant la période de temporisation de 30 jours (et cette période peut coïncider avec la période d’évaluation de l’entreprise en ligne), il est possible que l’entreprise en ligne ne puisse pas ajouter des objets supplémentaires à l’aide de la synchronisation d’annuaires. Cette condition se produit car le quota de service d’annuaire de l’entreprise en ligne a été atteint.

Dans ce scénario, l’entreprise en ligne qui effectue l’évaluation du service cloud doit réduire le nombre d’objets dans son environnement Active Directory DS local hors production pour terminer l’évaluation du produit. Toutefois, si l’entreprise en ligne ne peut pas réduire le nombre d’objets, elle doit demander une augmentation de son quota de service d’annuaire.

Question 3 : Le fait d’avoir plusieurs domaines vérifiés signifie-t-il que je peux avoir un quota supérieur à 300 000 objets ?

Réponse 3 : Non. Vous bénéficiez d’un quota d’annuaire de 300 000 objets si vous disposez d’un ou de plusieurs domaines vérifiés. Vous ne disposez pas d’un quota de 300 000 objets pour chaque domaine vérifié que vous inscrivez.

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