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Les rôles SAP des utilisateurs supprimés du système SAP n’ont pas pu être mis à jour - Événement 5009 (Duet Enterprise)

 

S’applique à : Duet Enterprise for Microsoft SharePoint and SAP

Dernière rubrique modifiée : 2011-08-05

Nom de l’alerte :   Les rôles SAP des utilisateurs supprimés du système principal n’ont pas pu être mis à jour

ID d’événement :   5009

Résumé

Les utilisateurs Duet Enterprise et leurs rôles sont synchronisés avec le système SAP et sont stockés dans le magasin de profils du service de profil utilisateur. L’une des fonctions du processus de synchronisation consiste à récupérer du système SAP la liste des rôles SAP supprimés et de mettre à jour le magasin de profils utilisateur en effaçant la propriété Rôles SAP pour les utilisateurs SAP supprimés. Le travail du minuteur Synchronisation des profils Duet Enterprise initie la synchronisation des utilisateurs du magasin de profils utilisateur SharePoint avec les rôles mappés dans le système SAP. Le compte de service Service du minuteur exécutant la synchronisation des profils Duet Enterprise doit disposer d’autorisations Contrôle total sur le service de profil utilisateur.

Symptômes

Cet événement apparaît dans le journal des événements :

ID d’événement : 5009 Description : les rôles SAP des utilisateurs supprimés du système principal n’ont pas pu être mis à jour. Message d’exception : <message>.

Cause

La ou les causes peuvent être les suivantes :

  • Le compte utilisé pour synchroniser les comptes d’utilisateurs dans le compte de service Service du minuteur avec le magasin de profils utilisateur dans la batterie SharePoint Server ne possède pas d’autorisations de contrôle total sur l’application de service Profil utilisateur.

    Pour plus d’informations sur la façon de fournir des autorisations de comptes gérés à un administrateur d’application de service pour une application de service Profil utilisateur spécifique, voir Assigner l’administration d’une application de service Profil utilisateur (SharePoint Server 2010) (https://go.microsoft.com/fwlink/?linkid=204625&clcid=0x40C).

  • La méthode DeletedIDEnumerator dans le modèle BDC qui est associée à la synchronisation des rôles pour Duet Enterprise génère une exception intermittente.

Résolution

Vérifier le compte de service

  1. Vérifiez que le compte d’utilisateur utilisé par le compte de service Service du minuteur pour effectuer cette procédure est membre du groupe Administrateurs sur le serveur.

  2. Cliquez sur Démarrer, pointez sur Outils d’administration , puis cliquez sur Services.

  3. Dans le composant logiciel enfichable Services, cliquez avec le bouton droit sur le service minuteur de SharePoint Services V4, puis cliquez sur Propriétés.

  4. Dans la boîte de dialogue Propriétés du service, sous l’onglet Se connecter, tapez le mot de passe du compte, confirmez-le puis cliquez sur OK.

  5. Cliquez avec le bouton droit sur le service, puis cliquez sur Démarrer.

Vérifier l’accès à l’application de service Profil utilisateur

  1. Vérifiez que vous disposez des informations d’identification administratives suivantes :

    • Vous devez être membre du groupe Administrateurs de batterie ou administrateur de l’application de service Profil utilisateur désignée.
  2. Dans la page d’accueil Administration centrale, dans la section Gestion des applications, cliquez sur Gérer les applications de service.

  3. Dans la page Gérer les applications de service, cliquez sur la ligne contenant l’application de service Profil utilisateur qui a été déployée pour Duet Enterprise.

    L’application de service Profil utilisateur pour votre installation de Duet Enterprise est spécifiée dans le fichier Duet EnterpriseDuetConfig.config.

  4. Dans le groupe Partage du Ruban, cliquez sur Autorisations.

  5. Dans la boîte de dialogue Autorisations de connexion, effectuez l’une des opérations suivantes :

    • Si le compte de service Service du minuteur figure dans le volet du milieu, cliquez sur le compte d’utilisateur.

    • Si le compte de service Service du minuteur ne figure pas dans le volet du milieu, tapez le compte d’utilisateur dans le volet supérieur, puis cliquez sur Ajouter.

  6. Dans le volet du bas, vérifiez que la case à cocher Contrôle total est activée.

  7. Cliquez sur OK.

    Pour plus d’informations, voir Restreindre ou autoriser l’accès à une application de service (SharePoint Server 2010) (https://go.microsoft.com/fwlink/?linkid=202009&clcid=0x40C).