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Les rôles dans SAP et le magasin de profils utilisateur ne sont pas synchronisés : événement 5008 (Duet Enterprise)

 

S’applique à : Duet Enterprise for Microsoft SharePoint and SAP

Dernière rubrique modifiée : 2011-08-05

Nom de l’alerte :   les rôles dans SAP et le magasin de profils utilisateur ne sont pas synchronisés

ID d’événement :   5008

Résumé

Les utilisateurs Duet Enterprise et leurs rôles sont synchronisés avec le système SAP et stockés dans le magasin de profils du service de profil utilisateur. L’une des fonctions du processus de synchronisation consiste à récupérer du système SAP la liste des rôles SAP supprimés et de mettre à jour le magasin de profils utilisateur en effaçant la propriété Rôles SAP pour les utilisateurs SAP supprimés. Le travail du minuteur Synchronisation des profils Duet Enterprise initie la synchronisation des utilisateurs du magasin de profils utilisateur SharePoint avec les rôles mappés dans le système SAP. Le compte de service Service du minuteur exécutant la synchronisation des profils Duet Enterprise doit disposer d’autorisations Contrôle total sur l’application du service de profil utilisateur.

Symptômes

Cet événement apparaît dans le journal des événements :

ID d’événement : 5008 Description : les rôles SAP des utilisateurs supprimés du système principal n’ont pas pu être mis à jour.

Cause

La ou les causes peuvent être les suivantes :

  • Un problème de connectivité réseau ou des erreurs transitoires sur le système SAP principal se sont produits.

  • L’application de service de profil utilisateur n’est pas en cours d’exécution.

  • Le compte du travail du minuteur ne dispose pas d’autorisations Contrôle total sur l’application de service de profil utilisateur.

    Pour plus d’informations sur la façon de fournir des autorisations de comptes gérés à un administrateur d’application de service pour une application de service Profil utilisateur spécifique, voir Assigner l’administration d’une application de service Profil utilisateur (SharePoint Server 2010) (https://go.microsoft.com/fwlink/?linkid=204625&clcid=0x40C).

  • La méthode DeletedIDEnumerator dans le modèle BDC associée à la synchronisation des rôles, qui extrait les utilisateurs supprimés du système principal, a échoué. Il se peut que l’administrateur SharePoint ne dispose pas des autorisations suffisantes sur le modèle BDC pour exécuter cette méthode.

Solution

Vérifier la connectivité réseau et la connectivité au système principal SAP

  • Exécutez une commande ping sur les serveurs dans la batterie distante pour vérifier qu’ils sont disponibles. Demandez à l’administrateur de la batterie distante d’exécuter une commande ping sur les serveurs dans votre batterie.

    Notes

    Contactez l’administrateur SAP et vérifiez qu’il n’existe aucun problème de connectivité sur le système SAP.

Démarrer le service de profil utilisateur

  1. Vérifiez que le compte d’utilisateur qui effectue cette procédure est membre du groupe SharePoint Administrateurs de batterie.

  2. Dans le site Web Administration centrale de SharePoint, cliquez sur Paramètres système.

  3. Dans la page Paramètres système, dans la section Serveurs, cliquez sur Gérer les services sur le serveur.

  4. Cliquez sur Démarrer dans la colonne Action pour le service de profil utilisateur.

  5. Cliquez sur OK pour démarrer le service.

Vérifier le compte de service

  1. Vérifiez que le compte d’utilisateur qui exécute cette procédure est membre du groupe Administrateurs sur l’ordinateur local.

  2. Cliquez sur Démarrer, pointez sur Outils d’administration , puis cliquez sur Services.

  3. Dans le composant logiciel enfichable Services, cliquez avec le bouton droit sur le service minuteur de SharePoint Services V4, puis cliquez sur Propriétés.

  4. Dans la boîte de dialogue Propriétés du service, sous l’onglet Se connecter, tapez le mot de passe du compte, confirmez-le puis cliquez sur OK.

  5. Cliquez avec le bouton droit sur le service, puis cliquez sur Démarrer.

Vérifier l’accès à l’application de service de profil utilisateur

  1. Sur la page d’accueil Administration centrale, dans la section Gestion des applications, cliquez sur Gérer les applications de service.

  2. Dans la page Gérer les applications de service, cliquez sur la ligne contenant l’application de service Profil utilisateur qui a été déployée pour Duet Enterprise.

    L’application de service Profil utilisateur pour votre installation de Duet Enterprise est spécifiée dans le fichier Duet EnterpriseDuetConfig.config.

  3. Dans le groupe Partage du Ruban, cliquez sur Autorisations.

  4. Dans la boîte de dialogue Autorisations de connexion, effectuez l’une des opérations suivantes :

    • Si le compte du travail du minuteur apparaît dans le volet du milieu, cliquez sur le compte d’utilisateur.

    • Si le compte du travail du minuteur n’apparaît pas dans le volet du milieu, tapez le compte d’utilisateur dans le volet du haut, puis cliquez sur Ajouter.

  5. Dans le volet du bas, vérifiez que la case à cocher Contrôle total est activée.

  6. Cliquez sur OK.

    Pour plus d’informations, voir Restreindre ou autoriser l’accès à une application de service (SharePoint Server 2010) (https://go.microsoft.com/fwlink/?linkid=202009&clcid=0x40C).