Impossible de synchroniser les magasins de profils SharePoint et SAP - Événement 5010 (Duet Enterprise)
S’applique à : Duet Enterprise for Microsoft SharePoint and SAP
Dernière rubrique modifiée : 2011-01-12
Nom de l’alerte : Impossible de synchroniser les magasins de profils SharePoint et SAP
ID d’événement : 5010
Résumé
Le travail du minuteur Synchronisation des profils Duet Enterprise synchronise les profils utilisateur contenus dans le magasin de profils utilisateur SharePoint avec les rôles SAP par le biais d’un connecteur Service Business Data Connectivity. Ce processus de synchronisation stocke les rôles SAP de chaque utilisateur Duet Enterprise dans le magasin de profils utilisateur SharePoint. Les modèles BDC fournis avec Duet Enterprise for Microsoft SharePoint and SAP contiennent les informations de connectivité et les propriétés d’authentification pour le système SAP. Les rôles SAP n’ont pas pu être synchronisés avec les profils utilisateur dans SharePoint Server.
Symptômes
L’événement suivant apparaît dans le journal des événements :
ID d’événement : 5010 Description : Échec de la validation de base de la synchronisation des rôles. Message d’exception : <message>.
Cause
Exécutez DuetConfig avec l’option /CheckConfiguration pour en savoir plus sur la cause de l’erreur et la résolution recommandée.
Résolution
Exécuter DuetConfig
Ouvrez une session sur un serveur Web frontal en tant que membre du groupe Administrateurs de batterie de serveurs.
Conseil
Vous ne devez effectuer cette procédure que sur un seul serveur Web frontal.
Ouvrez une invite de commandes en tant qu’administrateur :
Cliquez sur Démarrer, sur Tous les programmes, puis sur Accessoires.
Cliquez avec le bouton droit sur Invite de commandes, puis cliquez sur Exécuter en tant qu’administrateur.
Dans la fenêtre Invite de commandes, accédez au dossier qui contient le fichier DuetConfig.exe. Par défaut, il s’agit du dossier C:\program files\Duet Enterprise\1.0\.
Tapez DuetConfig**/CheckConfiguration out checkconfig.xml**, puis appuyez sur Entrée.
À l’invite de commandes, tapez notepad checkconfig.xml pour ouvrir le fichier .xml dans le Bloc-notes.
Vous pouvez également choisir d’ouvrir le fichier test.xml directement dans un navigateur (C:\Program Files\Duet Enterprise\1.0\test.xml).
Suivez les recommandations fournies dans le rapport afin de résoudre le problème.