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Outlook 2010, 2013, 2016 ou Outlook pour Microsoft 365 ne se connecte pas à Exchange à l’aide de MAPI sur HTTP comme prévu

Numéro de la base de connaissances d’origine : 2937684

Symptômes

Prenons l’exemple du scénario suivant :

  • Vous utilisez Microsoft Outlook 2010, Outlook 2013 Service Pack 1 (SP1) ou une version ultérieure.
  • Vous êtes connecté à une boîte aux lettres Microsoft Exchange Server 2013 SP1 ou Exchange Server 2016.
  • La boîte aux lettres Exchange et les serveurs d’accès au client (CAS) auxquels vous vous connectez ont tous installé Exchange Server 2013 SP1 ou une version ultérieure ou Exchange Server 2016.
  • Les paramètres de serveur nécessaires pour établir des connexions MapiHttp sont correctement configurés.

Dans le scénario ci-dessus, la colonne Protocole de la boîte de dialogue État de la connexion Outlook indique qu’Outlook 2013 est connecté au serveur Exchange à l’aide d’un mécanisme de connexion autre que MAPI/HTTP. Par exemple, la figure suivante montre une connexion utilisant RPC/HTTP.

Capture d’écran de la boîte de dialogue de status de connexion Outlook, qui montre la colonne Protocole en tant que RPC/HTTP.

Remarque

Les connexions MAPI/HTTP sont désignées dans la colonne Protocole à l’aide de la chaîne HTTP.

En outre, si MAPI/HTTP est désactivé, les utilisateurs de Microsoft 365 reçoivent une invite d’authentification de base au lieu d’une invite d’authentification moderne.

Cause

Ce problème peut se produire si la fonctionnalité MapiHttp est désactivée sur le client Outlook à l’aide de la valeur de Registre suivante :

Key: HKEY_CURRENT_USER\Software\Microsoft\Exchange
DWORD: MapiHttpDisabled
Value: 1

Résolution

Pour résoudre ce problème, remplacez la valeur de MapiHttpDisabled par 0 (zéro) ou supprimez la valeur DWORD MapiHttpDisabled . Ces données de Registre sont destinées à des fins de test uniquement.

  1. Quittez Outlook.

  2. Ouvrez le Registre Rédacteur en utilisant l’une des procédures suivantes, en fonction de votre version de Windows :

    • Windows 10, Windows 8.1 et Windows 8 : appuyez sur la touche Windows + R pour ouvrir la boîte de dialogue Exécuter. Tapez regedit.exe, puis appuyez sur OK.
    • Windows 7 : cliquez sur Démarrer, tapez regedit.exe dans la zone de recherche, puis appuyez sur Entrée.
  3. Recherchez et sélectionnez la clé de Registre suivante :

    HKEY_CURRENT_USER\Software\Microsoft\Exchange
    
  4. Cliquez avec le bouton droit sur MapiHttpDisabled , puis cliquez sur Modifier.

  5. Remplacez le paramètre Données de la valeur par 0 , puis cliquez sur OK.

  6. Fermez l’Éditeur du registre.

  7. Démarrez Outlook.

Informations supplémentaires

Pour plus d’informations sur la configuration requise pour les connexions MAPI sur HTTP, consultez MAPI sur HTTP.