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Erreur « Demander les autorisations de votre administrateur CRM pour accéder à Salesforce à l’aide d’API »

Cet article vous aide à résoudre les problèmes liés à l’affichage d’un message d’erreur après la connexion et la connexion à Salesforce CRM dans Microsoft Copilot for Sales.

Remarque

Microsoft Sales Copilot est renommé Microsoft Copilot for Sales en janvier 2024. Les captures d’écran de cet article seront bientôt mises à jour avec le nouveau nom.

Qui est concerné ?

Type d’exigence Description
Application cliente Complément Outlook Copilot for Sales
Plateforme Clients web et de bureau
Système d’exploitation Windows et Mac
Déploiement Géré par l’utilisateur et géré par l’administrateur
CRM Salesforce
Utilisateurs Utilisateurs essayant d’utiliser Copilot for Sales avec Salesforce CRM

Symptômes

Une fois que vous vous êtes connecté à Salesforce CRM via le complément Copilot for Sales pour Outlook, le message d’erreur suivant s’affiche :

Demander à votre administrateur CRM des autorisations pour accéder à Salesforce à l’aide d’API

Capture d’écran montrant l’erreur d’autorisation d’API.

Cause

Le problème se produit lorsque vous n’avez pas d’autorisations d’API dans Salesforce. Vous pouvez vérifier s’il s’agit de la cause racine du problème si vous voyez l’erreur suivante dans les journaux :

Exception thrown in VivaSalesContacts/GetContactsByEmailAddress - 
Microsoft.SalesProductivity.Common.Base.SPServiceException: Salesforce failed to complete task: Message: entity is deleted clientRequestId: {CLIENT REQUEST ID HERE}-self ---> 
System.Exception: { 
    "error": { 
        "code": 502, 
        "source": "{APIM SOURCE}", 
        "message": "BadGateway", 
        "innerError": { 
            "status": 502, 
            "message": "Salesforce failed to complete task: Message: **API is disabled for this User**\r\nclientRequestId: {CLIENT REQUEST ID HERE}", 
            "error": null, 
            "source": "Salesforce.Common", 
            "errors": [] 
        } 
    } 
} 

Résolution

Un admininstrator peut accorder l’autorisation API Activée à l’utilisateur ou au profil de l’utilisateur affecté en procédant comme suit :

  1. Connectez-vous à Salesforce en tant qu’administrateur.

  2. Dans la zone de recherche, entrez Utilisateur.

  3. Dans le volet de navigation gauche, sélectionnez Profils, puis sélectionnez le profil de l’utilisateur concerné.

  4. Dans la section Autorisations d’administration , sélectionnez API activée.

  5. Sélectionnez Enregistrer.

    Capture d’écran montrant l’option API Activée dans la page Profils.

Plus d’informations

Si votre problème n’est toujours pas résolu, accédez au Copilot for Sales - Microsoft Community Hub pour contacter nos experts.

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