Erreur « AADSTS65005 » lorsque vous essayez de vous connecter aux services cloud Microsoft
Symptômes
Lorsque vous utilisez une application d’entreprise pour vous connecter ou vous authentifier auprès de l’une des Services cloud Microsoft, comme Microsoft 365, Microsoft Intune, Microsoft Dynamics, Microsoft Power BI ou Microsoft Azure, ou Microsoft Entra ID applications federated Gallery, vous recevez le message d’erreur suivant :
AADSTS65005 : l’application cliente a demandé l’accès à la ressource. Cette demande a échoué, car le client n’a pas spécifié cette ressource dans sa liste requiredResourceAccess.
Cause
Ce problème se produit parce que l’application de l’entreprise peut ne pas être inscrite auprès de Microsoft Entra ID, ou qu’elle n’a pas les autorisations appropriées appliquées.
Résolution
Pour résoudre ce problème, utilisez l’une des ressources suivantes, en fonction des services auxquels vous essayez d’accéder :
- Microsoft 365 : inscrire manuellement votre application auprès de Microsoft Entra ID afin qu’elle puisse accéder aux API Microsoft 365
- Dynamics CRM : Inscrire l’application pour Dynamics CRM
- Problèmes de connexion à une application de galerie configurée pour l’authentification unique fédérée
Informations supplémentaires
Pour plus d’informations sur l’inscription de votre application auprès de Microsoft Entra ID, consultez le site web Microsoft suivant :