Les utilisateurs de dossiers publics ne peuvent pas renommer, déplacer ou supprimer des sous-dossiers
Symptômes
Une fois qu’un utilisateur a créé un sous-dossier dans un dossier public, il ne peut pas renommer, déplacer ou supprimer le sous-dossier.
Cause
La propriété de boîte aux lettres EffectivePublicFolderMailbox
utilisateur ne spécifie pas la boîte aux lettres de dossier public de hiérarchie principale pour votre organization Microsoft Exchange.
Un algorithme Exchange qui équilibre la charge des utilisateurs sur toutes les boîtes aux lettres de dossiers publics affecte automatiquement une EffectivePublicFolderMailbox
valeur à chaque boîte aux lettres utilisateur.
Si la valeur de la boîte aux lettres EffectivePublicFolderMailbox
utilisateur spécifie la boîte aux lettres de dossier public de hiérarchie principale pour votre organization Exchange, l’utilisateur dispose de l’autorisation Propriétaire sur les sous-dossiers de dossiers publics qu’il crée dans n’importe quelle boîte aux lettres de dossiers publics. L’autorisation Propriétaire permet aux utilisateurs de renommer, déplacer et supprimer ces sous-dossiers.
Si la valeur de la boîte aux lettres EffectivePublicFolderMailbox
utilisateur spécifie une boîte aux lettres de dossier public de hiérarchie secondaire, l’utilisateur hérite des autorisations de dossier parent sur les sous-dossiers publics qu’il crée dans n’importe quelle boîte aux lettres de dossiers publics. Le problème décrit dans la section « Symptômes » se produit si l’utilisateur dispose de l’une des autorisations de dossier public suivantes sur le dossier parent :
PublishingEditor : jeu d’autorisations en fonction du rôle qui inclut l’autorisation CreateSubfolders
PublishingAuthor : jeu d’autorisations en fonction du rôle qui inclut l’autorisation CreateSubfolders
CreateSubfolders : requis pour créer un sous-dossier
Solution de contournement
Pour contourner le problème, accordez à l’utilisateur l’autorisation Propriétaire sur les sous-dossiers qu’il crée ou doit gérer. Utilisez l’une des méthodes suivantes.
Remarque
Pour utiliser les méthodes suivantes, vous devez disposer d’autorisations d’administrateur.
Méthode 1 : Utiliser le Centre d’administration Exchange
Dans le Centre d’administration Exchange (EAC), accédez à Dossiers> publicsDossiers publics.
Accédez au sous-dossier de l’utilisateur, puis sélectionnez Gérer dans le volet droit.
Accordez à l’utilisateur l’autorisation Propriétaire sur le sous-dossier.
Remarque
En fonction de l’emplacement du dossier public et de votre environnement Exchange, utilisez Exchange Online ou le centre d’administration Exchange local.
Méthode 2 : Utiliser le client de bureau Outlook
Dans le client de bureau Microsoft Outlook, accédez au sous-dossier de l’utilisateur, puis ouvrez la fenêtre Propriétés .
Sous l’onglet Autorisations , sélectionnez le niveau d’autorisation Propriétaire , puis sélectionnez Ajouter pour spécifier l’utilisateur.
Méthode 3 : Utiliser PowerShell
Exécutez l’applet de commande Add-PublicFolderClientPermission pour accorder à l’utilisateur l’autorisation Propriétaire sur un sous-dossier :
Add-PublicFolderClientPermission -Identity <subfolder ID> -User <user ID> -AccessRights Owner
Remarque
Selon l’emplacement du dossier public et votre environnement Exchange, vous devrez peut-être d’abord connecter votre session PowerShell à Exchange Online. Pour les dossiers publics locaux, utilisez l’environnement de ligne de commande Exchange Management Shell (EMS).
Informations supplémentaires
Pour déterminer les autorisations utilisateur pour un dossier ou un sous-dossier public, case activée dans le Centre d’administration Exchange ou exécutez la commande suivante :
Get-PublicFolderClientPermission <folder ID> | FT FolderName,User,AccessRights
Pour déterminer la valeur de propriété
EffectivePublicFolderMailbox
d’une boîte aux lettres utilisateur, exécutez la commande suivante :Get-Mailbox -Identity <user mailbox> | FL Name,EffectivePublicFolderMailbox
Pour identifier la boîte aux lettres de dossiers publics de la hiérarchie principale pour votre organization Exchange, case activée dans LE CAE ou exécutez la commande suivante :
Get-Mailbox -PublicFolder | FT Name,IsRootPublicFolderMailbox