Erreur « Aucune boîte aux lettres de dossier public active n’a été trouvée » et le lot de migration échoue dans la commande Complete-MigrationBatch
Symptômes
Vous migrez des dossiers publics de Microsoft Exchange Server 2019, 2016 ou 2013 localement vers Exchange Online. L’environnement local a plusieurs domaines Active Directory (AD).
Lorsque vous exécutez la Complete-MigrationBatch
commande, le lot de migration passe à un état d’échec et génère le message d’erreur suivant :
"No active public folder mailboxes were found. This happens when no public folder mailboxes are provisioned or they are provisioned in 'HoldForMigration' mode."
Cause
Ce problème se produit, car la boîte aux lettres de dossier public et le compte d’utilisateur associé ne se trouve pas dans le même domaine AD. Par exemple, le compte d’utilisateur associé à la boîte aux lettres du dossier public se trouve dans contoso.com et la boîte aux lettres est hébergée dans Exchange Server dans child.contoso.com.
Résolution
Pour résoudre ce problème, déplacez le compte AD associé à la boîte aux lettres de dossier public vers le même domaine AD qui héberge Exchange Server. Par exemple, Exchange Server est installé dans le domaine AD racine (contoso.com), et le compte AD associé à la boîte aux lettres du dossier public se trouve dans le domaine enfant (child.contoso.com). Dans ce cas, déplacez le compte AD associé à la boîte aux lettres du dossier public vers le domaine racine (contoso.com), puis réexécutez la Complete-MigrationBatch
commande. Selon la version du système d’exploitation, vous pouvez utiliser l’outil de migration Active Directory ou la commande Move-ADObject pour déplacer l’utilisateur AD entre les domaines.
Par exemple, exécutez la commande PowerShell suivante pour déplacer l’utilisateur AD associé à PFMBX4 de child.contoso.com vers contoso.com :
Move-ADObject -Identity "CN=PFMBX4,CN=Users,DC=Child,DC=contoso,DC=com" -TargetPath "CN=Users,DC=contoso,DC=com" -TargetServer dc1.contoso.com