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La boîte aux lettres cible n’a pas de proxy smtp correspondant dans une migration de boîte aux lettres

Problème

Supposons que vous disposez d’un déploiement hybride de Microsoft Exchange Server et Exchange Online locaux dans Microsoft 365. Lorsque vous essayez de déplacer des boîtes aux lettres de votre environnement local vers Exchange Online, le message d’erreur suivant s’affiche :

La boîte aux lettres cible n’a pas de proxy smtp correspondant à «< domain.mail.onmicrosoft.com> »

Cause

Ce problème peut se produire lorsque lʼune des conditions suivantes est remplie :

  • La boîte aux lettres source n’est pas marquée pour avoir une <adresse smtp domain.mail.onmicrosoft.com>.
  • L’adresse <proxy domain.mail.onmicrosoft.com> n’est pas synchronisée avec Microsoft 365 sur l’objet utilisateur de messagerie cloud correspondant.

Solution

Pour trouver la cause du problème et déterminer à partir de quelle boîte aux lettres l’adresse <e-mail domain.mail.onmicrosoft.com> est manquante, exécutez les commandes suivantes dans Exchange Management Shell et Exchange Online PowerShell :

Scénario 1 : <l’adresse e-mail domain.mail.onmicrosoft.com> est manquante dans la boîte aux lettres source locale (Exchange Management Shell)

Pour résoudre ce problème, ajoutez l’adresse <de messagerie domain.mail.onmicrosoft.com> à la boîte aux lettres source locale.

Si une stratégie d’adresse e-mail est appliquée à la boîte aux lettres locale (autrement dit, si la valeur du paramètre EmailAddressPolicyEnabled a la valeur True ou que la case Mettre à jour automatiquement les adresses e-mail en fonction de la stratégie d’adresse e-mail appliquée à ce destinataire est activée pour l’utilisateur dans le Centre d’administration Exchange ou la console de gestion Exchange), cela signifie que la stratégie d’adresse e-mail ne contient pas le domaine> SMTP <secondaireDomaine .mail.onmicrosoft.com dans le modèle de stratégie d’adresse e-mail. Vous pouvez vérifier cette stratégie en exécutant la commande suivante dans Exchange Management Shell :

Get-EmailAddressPolicy | FL Identity, EnabledEmailAddressTemplates  

Dans ce cas, ajoutez <domain.mail.onmicrosoft.com> à la stratégie d’adresse e-mail. Pour cela, procédez comme suit :

  1. Ouvrez le Centre d’administration Exchange sur le serveur Exchange local.

  2. Cliquez sur Flux de courrier, puis sur Stratégies d’adresse de messagerie.

  3. Sélectionnez la stratégie d’adresse e-mail que vous souhaitez modifier, puis cliquez sur Modifier.

  4. Au format d’adresse e-mail, ajoutez le domaine (<domain.mail.onmicrosoft.com>) à la stratégie, cliquez sur Enregistrer, puis sur Appliquer à pour appliquer la modification aux destinataires.

  5. Vous devez maintenant voir que l’adresse <SMTP domain.mail.onmicrosoft.com> est marquée sur la boîte aux lettres locale lorsque vous exécutez la commande suivante :

    Get-Mailbox <AffectedUser> | FL EmailAddresses, EmailAddressPolicyEnabled
    
  6. Attendez l’exécution de la synchronisation d’annuaires. Vous pouvez également forcer une synchronisation d’annuaires delta. Pour plus d’informations sur la procédure à suivre, consultez Démarrer le planificateur.

Si aucune stratégie d’adresse e-mail n’est appliquée à la boîte aux lettres locale (autrement dit, si la valeur du paramètre EmailAddressPolicyEnabled est False ou que la case Mettre à jour automatiquement les adresses e-mail en fonction de la stratégie d’adresse de messagerie appliquée à ce destinataire n’est pas sélectionnée pour l’utilisateur dans le Centre d’administration Exchange ou la Console de gestion Exchange), ou si, pour une raison quelconque, la stratégie d’adresse de messagerie n’est pas marquée ou n’applique pas la user@domain.mail.onmicrosoft.com stratégie d’adresse e-mail. adresse smtp sur le destinataire, vous devez ajouter manuellement l’adresse <de messagerie domain.mail.onmicrosoft.com> sur l’utilisateur, puis synchroniser la modification avec l’ID Microsoft Entra. Pour cela, procédez comme suit :

  1. Ouvrez le Centre d’administration Exchange sur le serveur Exchange local.

  2. Cliquez sur destinataires, puis cliquez sur boîtes aux lettres.

  3. Sélectionnez et double-cliquez sur la boîte aux lettres locale que vous souhaitez modifier.

  4. Dans Adresses de messagerie, cliquez sur l’icône Ajouter () pour ajouter user@domain.mail.onmicrosoft.com une adresse e-mail aux adresses e-mail de l’utilisateur.

  5. Cliquez sur OK, puis sur Enregistrer.

  6. Le fichier domain.mail.onmicrosoft.com> doit maintenant être <marqué sur la boîte aux lettres locale lorsque vous exécutez la commande suivante :

    Get-Mailbox <AffectedUser> | FL EmailAddresses
    
  7. Attendez l’exécution de la synchronisation d’annuaires. Vous pouvez également forcer une synchronisation d’annuaires delta. Pour plus d’informations sur la procédure à suivre, consultez Démarrer le planificateur.

Scénario 2 : <domain.mail.onmicrosoft.com> adresse e-mail est horodatée sur la boîte aux lettres source locale, mais est manquante dans l’objet utilisateur de messagerie cloud (Exchange Online PowerShell)

Dans ce cas, vous rencontrez probablement un problème de synchronisation. Déterminez si la synchronisation d’annuaires fonctionne et si vous avez des erreurs de synchronisation signalées dans l’outil Microsoft Entra Connect ou le Centre d’administration Microsoft 365. Pour plus d’informations sur la procédure à suivre, consultez Afficher les erreurs de synchronisation d’annuaires dans Microsoft 365.

Vous pouvez également avoir une erreur de validation utilisateur si vous avez déjà un objet utilisateur cloud sur lequel l’adresse user@domain.mail.onmicrosoft.com e-mail est marquée.

Pour voir cette erreur, vous devez vous connecter à Microsoft 365 PowerShell , puis exécuter l’une des commandes suivantes, selon que vous vous connectez au service MSOnline (MSOL) ou à l’ID Microsoft Entra pour Windows PowerShell :

(Get-MsolUser -UserPrincipalName <AffectedUserUPN>).Errors.ErrorDetail.ObjectErrors.ErrorRecord.ErrorDescription
(Get-AzureADUser -ObjectId <AffectedUserUPN>).Errors.ErrorDetail.ObjectErrors.ErrorRecord.ErrorDescription

Remarque

Les modules PowerShell Azure AD et MSOnline seront obsolètes à compter du 30 mars 2024. Pour en savoir plus, consultez la mise à jour sur l’obsolescence. Après cette date, la prise en charge de ces modules sera limitée à l’assistance à la migration vers le kit de développement logiciel Microsoft Graph PowerShell et aux correctifs de sécurité. Les modules obsolètes continueront de fonctionner jusqu’au 30 mars 2025.

Nous vous recommandons de migrer vers Microsoft Graph PowerShell pour interagir avec Microsoft Entra ID (anciennement Azure AD). Pour toutes questions liées à la migration, consultez la FAQ sur la migration. Remarque : les versions 1.0.x de MSOnline pourront subir des perturbations après le 30 juin 2024.

Pour plus d’informations, consultez Vous voyez des erreurs de validation pour les utilisateurs dans le portail Microsoft 365 ou dans le module Azure Active Directory pour Windows PowerShell.

Ensuite, dans Microsoft 365 PowerShell, vérifiez si les adresses proxy dans l’ID Microsoft Entra contiennent l’adresse user@domain.mail.onmicrosoft.come-mail . Pour ce faire, exécutez l’une des commandes suivantes :

(Get-MsolUser -UserPrincipalName <AffectedUserUPN>).ProxyAddresses
(Get-AzureADUser -ObjectId <AffectedUserUPN>).ProxyAddresses

Si vous trouvez l’adresse user@domain.mail.onmicrosoft.com smtp de l’utilisateur dans le résultat de la commande, mais que vous n’avez toujours pas cette adresse e-mail dans Exchange Online PowerShell à l’aide de la Get-MailUser commande , cela signifie que l’outil de synchronisation d’annuaires a correctement placé l’adresse dans l’ID Microsoft Entra et que vous rencontrez probablement un problème de synchronisation entre l’ID Microsoft Entra et Exchange Online.

Une autre cause peut être si le domain.mail.onmicrosoft.com domaine smtp qui est marqué sur l’utilisateur local est incorrect. Par exemple, le domaine n’existe pas dans votre client Microsoft 365 ou les domaines Exchange Online acceptés. Pour plus d’informations sur les domaines acceptés, consultez Afficher les domaines acceptés.

Si vous ne pouvez pas déterminer la cause du problème, ouvrez un dossier de support auprès de l’équipe de support Microsoft pour examiner plus en détail.

Informations supplémentaires

Pour plus d’informations sur les stratégies d’adresse e-mail et les déploiements hybrides Exchange, consultez la section « Stratégie d’adresse de messagerie » du billet de blog Le cloud à vos conditions (PARTIE I : déploiement hybride ).

Pour plus d’informations sur la modification d’une stratégie d’adresse e-mail, consultez Modifier une stratégie d’adresse e-mail.

Pour plus d’informations sur le domaine de coexistence ajouté par l’Assistant Configuration hybride, consultez l’entrée « Domaines » dans Assistant Configuration hybride.

Encore besoin d’aide ? Accédez à Microsoft Community ou aux forums TechNet sur Exchange.