Impossible de mettre à jour une ligne de chargement, car la quantité libérée serait négative
Code d’erreur :@WAX:ReleasedQtyCannotBeNegative
Symptômes
Ce problème se produit lorsque la mise à jour ou la suppression d’une ligne de chargement entraîne une quantité libérée négative. Dans ce cas, lorsque vous essayez de mettre à jour ou de supprimer la ligne de chargement, le système affiche le message d’erreur suivant :
La quantité libérée ne peut pas être négative pour l’article %1, lot %2.
Par conséquent, vous ne pouvez pas mettre à jour ou supprimer la ligne de chargement.
Cause
Après avoir mis à jour ou supprimé une ligne de chargement, le système met à jour la quantité libérée de la ligne de vente associée (whsSalesLine.ReleaseQty). Le système évalue la quantité libérée et, s’il constate que la quantité libérée de la ligne est négative après la mise à jour, il ne vous permet pas de mettre à jour ou de supprimer la ligne. Cette validation se produit chaque fois que vous essayez de mettre à jour la quantité de ligne de chargement ou l’unité de mesure par le biais de diverses actions, telles que la suppression d’une ligne de chargement, la suppression d’une expédition, la modification de la quantité d’une ligne de chargement, la réduction de la quantité choisie et le prélèvement court.
La cause racine la plus courante de ce problème est une modification de la conversion d’unité utilisée pour les lignes de chargement ouvertes. Par exemple, la conversion d’unité lors de la publication d’une commande client était de 50 Ea = 1 PL. Toutefois, avant la finalisation de l’expédition de charge associée, la conversion d’unité a été changée en 100 Ea = 1 PL.
Résolution
La solution consiste à annuler les modifications de conversion d’unités, à mettre à jour ou à supprimer la ligne de chargement, puis à réapplémenter la conversion. Vous devez empêcher le traitement d’autres charges incluant l’élément à l’origine du problème tant que le problème n’est pas résolu. Sinon, les nouvelles conversions peuvent être utilisées pour d’autres charges déjà ouvertes.
Pour résoudre ce problème, effectuez les tâches suivantes :
- Passez en revue la conversion d’unité utilisée pour la ligne de chargement.
- Passez en revue la conversion d’unité actuelle pour l’élément et effectuez des ajustements qui permettront la mise à jour ou la suppression de la ligne de chargement.
- Mettez à jour ou supprimez la ligne de chargement, puis rétablissez les ajustements de conversion d’unité.
Passer en revue la conversion d’unité utilisée pour la ligne de chargement
Utilisez la procédure suivante pour passer en revue vos lignes de chargement et prendre note de la conversion d’unité utilisée pour la ligne de chargement.
- Accédez à Gestion de> l’entrepôtCharge>toutes les charges.
- Sélectionnez la charge qui inclut la ligne de chargement qui ne peut pas être supprimée ou mise à jour.
- Dans le volet Action, sous l’onglet Chargements , dans le groupe Informations associées , sélectionnez Travail.
- Dans la grille supérieure, sélectionnez l’ID de travail approprié.
- Sous l’onglet Général en bas de la page, calculez le taux de conversion entre la valeur quantité de travail d’inventaire et la valeur quantité de travail . Notez le taux.
- Répétez cette procédure pour tous les ID de travail pertinents pour vous assurer que la même conversion a été utilisée.
Passer en revue la conversion d’unité actuelle pour l’élément et effectuer des ajustements
Utilisez la procédure suivante pour passer en revue la conversion d’unité de votre produit et effectuer des ajustements pour vous assurer que la conversion d’unité est alignée sur la ligne de chargement.
- Accédez à Gestion des informations sur les>produits Produits>produits.
- Ouvrez le produit approprié pour accéder à sa page Détails du produit publié .
- Dans le volet Action, sous l’onglet Produit , dans le groupe Configurer , sélectionnez Conversions d’unités.
- Sélectionnez la conversion entre les unités et effectuez des ajustements à l’aide de la conversion que vous avez trouvée dans la section précédente.
Mettre à jour ou supprimer la ligne de chargement et rétablir les ajustements de conversion d’unités
Utilisez la procédure suivante pour traiter la ligne de chargement en fonction des besoins et rétablir les conversions d’unités.
- Accédez à Gestion de> l’entrepôtCharge>toutes les charges.
- Ouvrez le chargement qui inclut la ligne de chargement qui ne peut pas être supprimée ou mise à jour.
- Dans l’onglet FastTab Charger les lignes , sélectionnez la ligne de chargement.
- Poursuivez avec les actions requises si nécessaire. (Par exemple, supprimez la ligne de chargement ou modifiez sa quantité.)
- Accédez à Gestion des informations sur les>produits Produits>produits.
- Ouvrez le produit approprié pour accéder à sa page Détails du produit publié .
- Dans le volet Action, sous l’onglet Produit , dans le groupe Configurer , sélectionnez Conversions d’unités.
- Sélectionnez la conversion entre les unités et rétablissez les ajustements que vous avez effectués dans la section précédente.