Partager via


La quantité ne peut pas être réduite lorsqu’une commande commerciale est annulée

Code d’erreur : SYS138831

Symptômes

Le système affiche le message d’erreur suivant :

La quantité ne peut pas être réduite. Le nombre de transactions d’inventaire sur commande est trop faible, car la quantité ou la partie de celle-ci est référencée par un ordre de sortie ou un ordre de production ou est marquée par rapport à d’autres transactions.

Cause

Si le travail est associé à une commande client, vous ne pouvez pas annuler la commande tant que le travail n’est pas annulé et inversé. Cette exigence s’applique même si le travail associé à la commande commerciale est fermé.

Résolution

Pour résoudre ce problème, effectuez les tâches suivantes :

  1. Annuler le travail ouvert.
  2. Supprimez la charge.
  3. Réduisez la quantité choisie.

Annuler le travail ouvert

Pour annuler le travail ouvert, procédez comme suit.

  1. Accédez à La gestion de l’entrepôt>tâches périodiques>Nettoyer le>travail Annuler.
  2. Dans le champ ID de travail, spécifiez l’ID du travail que vous souhaitez annuler, et qui a actuellement une valeur d’état De travail Open, In progress, Canceled, Combined ou Closed.
  3. Cliquez sur OK.
  4. Sélectionnez Oui pour confirmer que vous souhaitez annuler le travail.

Supprimer la charge

Pour supprimer une charge, procédez comme suit.

  1. Accédez à Ventes et marketing>Commandes client>Toutes les commandes client.
  2. Ouvrez les commandes clients concernées.
  3. Dans le raccourci Lignes de commande client, sélectionnez Entrepôt>Détails du travail.
  4. Dans la page Travail, dans le volet Action, sous l’onglet Travail, dans le groupe de travail, sélectionnez Annuler le travail.
  5. Vérifiez que le champ État du travail est défini sur Canceled.
  6. Fermez la page Travail.
  7. Dans la page détails de la commande client, dans les lignes de commandes Sales, fastTab, sélectionnez Les détails du chargement de l’entrepôt>.
  8. Dans le volet Actions, sélectionnez Supprimer.
  9. Sélectionnez Oui pour confirmer que vous souhaitez supprimer le chargement.
  10. Fermez la page Charger .

Réduire la quantité choisie

Une fois que tout le travail a été annulé, procédez comme suit pour réduire la quantité choisie.

  1. Accédez à Ventes et marketing>Commandes client>Toutes les commandes client.
  2. Ouvrez les commandes clients concernées.
  3. Dans les lignes de commande client FastTab, sélectionnez Mettre à jour la sélection de ligne> dans la barre d’outils.
  4. Dans la page Choisir , dans la section Transactions , sélectionnez la ligne dans laquelle le champ État du problème est défini sur Sélectionné.
  5. Dans la section Transactions , sélectionnez Ajouter une ligne de sélection dans la barre d’outils.
  6. Dans la section Sélection de lignes , sélectionnez Confirmer tout sélectionner dans la barre d’outils.
  7. Fermez la page Choisir .
  8. Dans la page détails de la commande client, dans le volet Action, sous l’onglet Commandes client, dans le groupe Gérer , sélectionnez Annuler.
  9. Sélectionnez Oui pour confirmer que vous souhaitez annuler la commande.