La quantité ne peut pas être réduite lorsqu’une commande commerciale est annulée
Code d’erreur : SYS138831
Symptômes
Le système affiche le message d’erreur suivant :
La quantité ne peut pas être réduite. Le nombre de transactions d’inventaire sur commande est trop faible, car la quantité ou la partie de celle-ci est référencée par un ordre de sortie ou un ordre de production ou est marquée par rapport à d’autres transactions.
Cause
Si le travail est associé à une commande client, vous ne pouvez pas annuler la commande tant que le travail n’est pas annulé et inversé. Cette exigence s’applique même si le travail associé à la commande commerciale est fermé.
Résolution
Pour résoudre ce problème, effectuez les tâches suivantes :
- Annuler le travail ouvert.
- Supprimez la charge.
- Réduisez la quantité choisie.
Annuler le travail ouvert
Pour annuler le travail ouvert, procédez comme suit.
- Accédez à La gestion de l’entrepôt>tâches périodiques>Nettoyer le>travail Annuler.
- Dans le champ ID de travail, spécifiez l’ID du travail que vous souhaitez annuler, et qui a actuellement une valeur d’état De travail Open, In progress, Canceled, Combined ou Closed.
- Cliquez sur OK.
- Sélectionnez Oui pour confirmer que vous souhaitez annuler le travail.
Supprimer la charge
Pour supprimer une charge, procédez comme suit.
- Accédez à Ventes et marketing>Commandes client>Toutes les commandes client.
- Ouvrez les commandes clients concernées.
- Dans le raccourci Lignes de commande client, sélectionnez Entrepôt>Détails du travail.
- Dans la page Travail, dans le volet Action, sous l’onglet Travail, dans le groupe de travail, sélectionnez Annuler le travail.
- Vérifiez que le champ État du travail est défini sur Canceled.
- Fermez la page Travail.
- Dans la page détails de la commande client, dans les lignes de commandes Sales, fastTab, sélectionnez Les détails du chargement de l’entrepôt>.
- Dans le volet Actions, sélectionnez Supprimer.
- Sélectionnez Oui pour confirmer que vous souhaitez supprimer le chargement.
- Fermez la page Charger .
Réduire la quantité choisie
Une fois que tout le travail a été annulé, procédez comme suit pour réduire la quantité choisie.
- Accédez à Ventes et marketing>Commandes client>Toutes les commandes client.
- Ouvrez les commandes clients concernées.
- Dans les lignes de commande client FastTab, sélectionnez Mettre à jour la sélection de ligne> dans la barre d’outils.
- Dans la page Choisir , dans la section Transactions , sélectionnez la ligne dans laquelle le champ État du problème est défini sur Sélectionné.
- Dans la section Transactions , sélectionnez Ajouter une ligne de sélection dans la barre d’outils.
- Dans la section Sélection de lignes , sélectionnez Confirmer tout sélectionner dans la barre d’outils.
- Fermez la page Choisir .
- Dans la page détails de la commande client, dans le volet Action, sous l’onglet Commandes client, dans le groupe Gérer , sélectionnez Annuler.
- Sélectionnez Oui pour confirmer que vous souhaitez annuler la commande.