Partager via


La quantité ne peut pas être réduite lorsqu’une commande client est annulée

Code d’erreur : SYS138831

Symptômes

Le système affiche le message d’erreur suivant :

La quantité ne peut pas être réduite. Le nombre de transactions d’inventaire sur commande est trop faible, car la quantité ou une partie de celle-ci est référencée par un ordre de sortie ou un ordre de production ou est marquée par rapport à d’autres transactions.

Cause

Si le travail est associé à une commande client, vous ne pouvez pas annuler la commande client tant que le travail n’est pas annulé et inversé. Cette exigence s’applique même si le travail associé à la commande client est fermé.

Résolution

Pour résoudre ce problème, effectuez les tâches suivantes :

  1. Annuler le travail ouvert.
  2. Supprimez la charge.
  3. Réduisez la quantité choisie.

Annuler le travail ouvert

Pour annuler le travail ouvert, procédez comme suit.

  1. Accédez à Gestion de> l’entrepôtTâches périodiques>Nettoyer>Annuler le travail.
  2. Dans le champ ID de travail, spécifiez l’ID du travail que vous souhaitez annuler et dont la valeur status de travail est Ouverte, En cours, Annulée, Combinée ou Fermée.
  3. Sélectionnez OK.
  4. Sélectionnez Oui pour confirmer que vous souhaitez annuler le travail.

Supprimer la charge

Pour supprimer une charge, procédez comme suit.

  1. Accédez à Ventes et marketing>Commandes> clientToutes les commandes client.
  2. Ouvrez la commande client appropriée.
  3. Dans l’onglet Rapide Lignes de commande ventes, sélectionnezDétails du travailde l’entrepôt>.
  4. Dans la page Travail , dans le volet Action, sous l’onglet Travail , dans le groupe Travail , sélectionnez Annuler le travail.
  5. Vérifiez que le champ Status de travail est défini sur Annulé.
  6. Fermez la page Travail .
  7. Dans la page détails de la commande client, dans l’onglet Lignes de commandes client, sélectionnezDétails du chargement de l’entrepôt>.
  8. Dans le volet Actions, sélectionnez Supprimer.
  9. Sélectionnez Oui pour confirmer que vous souhaitez supprimer la charge.
  10. Fermez la page Charger .

Réduire la quantité choisie

Une fois que tout le travail a été annulé, suivez ces étapes pour réduire la quantité choisie.

  1. Accédez à Ventes et marketing>Commandes> clientToutes les commandes client.
  2. Ouvrez la commande client appropriée.
  3. Dans l’onglet FastTab Lignes de commande client , sélectionnez Mettre à jour la ligne>Choisir dans la barre d’outils.
  4. Dans la page Choisir, dans la section Transactions, sélectionnez la ligne où le champ Problème status est défini sur Sélectionné.
  5. Dans la section Transactions , sélectionnez Ajouter une ligne de sélection dans la barre d’outils.
  6. Dans la section Lignes de sélection , sélectionnez Confirmer tout choisir dans la barre d’outils.
  7. Fermez la page Choisir .
  8. Dans la page détails de la commande client, dans le volet Actions, sous l’onglet Commande client , dans le groupe Gérer , sélectionnez Annuler.
  9. Sélectionnez Oui pour confirmer que vous souhaitez annuler la commande client.