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Dépannage des adaptateurs LOB (Line of Business) non-WCF

Erreur « Échec d’extraction »

Lors de l’utilisation d’un adaptateur LOB (Line of Business) non-WCF, les erreurs suivantes peuvent se produire :

  • Échec d’extraction du système

  • Agent de navigation : erreur interceptée dans le constructeur. L’ordinateur cible a expressément refusé la connexion.

  • Agent d’exécution : erreur interceptée dans le constructeur. L’ordinateur cible a expressément refusé la connexion.

Cause

Les adaptateurs LOB utilisent l’accès à distance .NET. Si l’activation de l’accès à distance .NET prend plus de temps que prévu, l’adaptateur risque de renvoyer ces erreurs.

Résolution

Créez la clé de Registre StartAgentSleep et augmentez la valeur du délai d’expiration :

  1. Ouvrez le Registre et accédez à HKEY_LOCAL_MACHINE\software\Microsoft\BizTalkAdapters.

  2. Créez une valeur DWORD avec les propriétés suivantes :

    Nom : StartAgentSleep

    Base : décimal

    Données de valeur : 1000

    Les données de la valeur sont mesurées en millisecondes (ms). 1 000 ms équivalent à 1 seconde.

    Dans certains systèmes, une seconde n’est pas une valeur suffisante. Augmentez la valeur et testez le résultat pour déterminer le délai d’attente approprié nécessaire.

Important

L’ajout de la clé de Registre StartAgentSleep a un impact sur tous les adaptateurs LOB non WCF.

Voir aussi

Dépannage des adaptateurs BizTalk Server