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Résolution des problèmes d’administration BizTalk Server

Cette section centralise les informations sur les problèmes connus rencontrés lors de l'utilisation de la console Administration de BizTalk Server.

Outre les problèmes connus suivants, la console d’administration BizTalk Server contient des informations supplémentaires sur les problèmes courants et les résolutions.

Problèmes connus

L'attente liée au démarrage du service d'authentification unique de l'entreprise empêche le démarrage du service BizTalk Server

Problème

Le redémarrage de votre ordinateur sans que le démarrage automatique du coordinateur DTC soit défini peut empêcher le démarrage du service BizTalk Server.

Cause

Un délai nécessaire au démarrage du service d'authentification unique de l'entreprise supérieur à celui autorisé par la durée d'expiration du service BizTalk Server peut provoquer ce problème.

Solution

Pour résoudre ce problème, définissez le démarrage automatique du coordinateur DTC. Si DTC est en cluster, il doit être défini sur un démarrage manuel, car le service de cluster gère le démarrage et l’arrêt des services en cluster.

Des ressources SQL peuvent être verrouillées

Problème

L'erreur suivante peut se produire :

La transaction (ID de processus 95) a été bloquée sur les ressources de verrouillage par un autre processus et a été choisie comme victime. Relancez la transaction.

Cause

Dans cette situation très rare, les opérations d'administration effectuées par un utilisateur entraînent l'exclusion d'un autre utilisateur de l'administration des bases de données.

Solution

Le problème doit se résoudre rapidement de lui-même. Réessayez l'opération après quelques instants.

La base de données SQL peut être verrouillée

Problème

Les utilisateurs peuvent être exclus de la base de données SQL. Divers messages d'erreur peuvent être renvoyés.

Cause

Dans certains cas, les opérations d'écriture dans la base de données effectuées par un utilisateur provoquent l'exclusion d'un autre utilisateur de la base de données.

Solution

Le problème doit se résoudre rapidement de lui-même. Réessayez l'opération après quelques instants.

L'arrêt de plusieurs instances de service dans un environnement incluant plusieurs bases de données MessageBox échoue avec une erreur

Problème

Les tentatives d'arrêt de plusieurs instances de service à l'aide de la console Administration de BizTalk Server échouent et une erreur similaire à celle indiquée ci-après est affichée :

Le serveur SQL Server a bloqué l'accès à la procédure « sys.xp_sqlagent_enum_jobs » du composant « Agent XPs » car celui-ci est désactivé dans le cadre de la configuration de sécurité du serveur.

Notes

Ce problème se produit dans un environnement incluant plusieurs bases de données MessageBox.

Cause

Ce problème peut se produire dans plusieurs environnements messagebox si le travail de l’agent SQL « Operations_OperateOnInstances_OnMaster_<dbName> » n’est pas en cours d’exécution sur les bases de données messagebox secondaires. Ce travail doit être exécuté pour propager les informations des bases de données MessageBox secondaires à la base de données MessageBox principale. L'exécution de ce travail échoue si celui-ci n'est pas activé ou si un échec de connexion se produit.

Solution

Si vous utilisez la console Administration BizTalk pour effectuer des opérations simultanément sur plusieurs instances de service et que votre environnement de BizTalk Server est configuré avec plusieurs bases de données messagebox, vérifiez que le travail SQL Server Agent nommé « Operations_OperateOnInstances_OnMaster_<dbName> » est activé sur toutes les boîtes de messages secondaires (non master) Bases. En outre, le service SQL Server Agent sur l'ordinateur SQL Server qui héberge les bases de données MessageBox secondaires doit être exécuté comme compte inclus dans le rôle BTS_SQLAGENT_USER de la base de données MessageBox secondaire.

Notes

<Dbname> est un espace réservé pour le nom réel de la base de données messagebox BizTalk.

Pour ajouter le compte de service SQL Server Agent au rôle BTS_SQLAGENT_USER de la base de données MessageBox secondaire, procédez comme suit :

Sous SQL Server 2008

  1. Cliquez sur Démarrer, pointez sur Tous les programmes, sur Microsoft SQL Server 2008, puis cliquez sur SQL Server Management Studio.

  2. Lorsque vous y êtes invité, choisissez le type de serveurmoteur de base de données et entrez ou sélectionnez le nom du serveur qui héberge la base de données de boîte de messages secondaire.

  3. Cliquez pour développer Bases de données, cliquez sur pour développer la base de données de boîte de messages secondaire, cliquez sur pour développer Sécurité, cliquez sur pour développer Rôles, cliquez sur pour développer les rôles de base de données, puis double-cliquez sur le rôle de base de données BTS_SQLAGENT_USER.

  4. Cliquez sur le bouton Add .

  5. Cliquez sur Parcourir, sélectionnez un groupe dont le compte de service SQL Server Agent est membre, puis cliquez sur OK.

Notes

Si le compte de service SQL Server Agent n'est pas membre du groupe spécifié, vous devez l'ajouter au groupe.

Les modifications apportées dans une instance de la console Administration de BizTalk ne sont pas automatiquement répercutées dans les autres instances de la console

Problème

Si plusieurs instances de la console Administration de BizTalk sont simultanément connectées au même groupe BizTalk Server, les modifications apportées dans une instance ne sont pas automatiquement répercutées dans les autres. Cela peut générer des erreurs de violation d'accès lors de la tentative de modification d'un artefact affiché dans une instance de la console si l'état de celui-ci ne correspond pas à l'état réel de l'artefact stocké dans la base de données de gestion BizTalk.

Cause

Chaque instance de la console Administration de BizTalk gère son propre cache de la configuration de groupe BizTalk et répercute uniquement les modifications dans celui-ci. Le cache est uniquement mis à jour lors de l'actualisation de la console.

Résolution

Si vous recevez des erreurs de violation d’accès concurrentiel dans la console Administration BizTalk, mettez à jour le cache de la instance de la console Administration BizTalk en cliquant sur le bouton Actualiser dans la barre d’outils de la console Administration BizTalk ou en appuyant sur la touche F5.

L'erreur « Impossible d'exécuter l'action Arrêter » se produit lorsque vous tentez d'arrêter une orchestration à l'aide de la console Administration de BizTalk

Problème

Lorsque vous tentez d'arrêter une orchestration à l'aide de la console Administration de BizTalk, un message d'erreur similaire à celui indiqué ci-après est généré :

Failed to execute action 'Stop'.
------------------------------
ADDITIONAL INFORMATION:
A transport-level error has occurred when sending the request to the server. (provider: TCP Provider, error: 0 - An existing connection was forcibly closed by the remote host.) (Microsoft SQL Server, Error: 10054)

Ce problème peut se produire si les conditions suivantes sont remplies :

  • La console Administration de BizTalk est ouverte.

  • La base de données de gestion BizTalk est installée sur une instance mise en cluster de SQL Server.

  • L'instance mise en cluster de SQL Server est basculée.

  • Une fois le basculement terminé, vous tentez d'arrêter une instance en cours d'exécution d'une orchestration à l'aide de la console Administration de BizTalk.

Cause

La console Administration BizTalk maintient une connexion à la base de données de gestion BizTalk Server. Lorsque la connexion à BizTalk Server base de données de gestion a été interrompue pendant le basculement, certaines tâches de gestion peuvent renvoyer une erreur « Échec de la connexion » ou « Échec de l’exécution » jusqu’à ce que la console Administration BizTalk ait été fermée et rouverte.

Résolution

Fermez, puis réouvrez la console Administration de BizTalk. Lorsque la console d’administration BizTalk est rouverte, elle crée une connexion à la base de données de gestion BizTalk Server spécifiée.

Les noms de groupe Windows précédemment supprimés n'ont pas accès aux bases de données BizTalk Server

Problème

Si, lors de la réinstallation de BizTalk Server, vous utilisez un nom de groupe Windows précédemment supprimé, le groupe Windows n’a pas accès aux bases de données BizTalk Server.

Cause

La suppression d'un groupe Windows suivie de la création d'un groupe portant le même non génère un nouveau SID (Security Identifier) pour ce groupe. Cependant, l'ancien SID est toujours mis en cache dans SQL Server, ce qui empêche le nouveau groupe Windows de se connecter à SQL Server.

Résolution

Lorsque vous supprimez le groupe Windows, vous devez également supprimer la connexion SQL Server de celui-ci.

L'administrateur BizTalk ne parvient pas à démarrer la console Administration de BizTalk Server

Problème

Un administrateur BizTalk (membre du groupe Windows des administrateurs BizTalk) peut ne pas parvenir à ouvrir la console Administration de BizTalk Server s'il n'est pas membre du groupe des administrateurs Windows sur l'ordinateur local.

Cause

Ce problème peut se produire si vous avez réinstallé ou reconfiguré BizTalk Server. Cela est dû au fait que SQL Server utilisait des ID de sécurité mis en cache.

Résolution

Ajoutez temporairement l'administrateur BizTalk au groupe des administrateurs Windows local sur l'ordinateur local. Après avoir ouvert la console Administration de BizTalk Server, supprimez-le.

Impossible de démarrer une instance d'hôte sur un ordinateur distant

Problème

Lorsque vous créez un instance hôte BizTalk sur un ordinateur distant, vous pouvez voir l’erreur suivante lorsque vous démarrez l’hôte BizTalk instance : « Échec du démarrage en raison d’un échec d’ouverture de session ».

Cause

Cette erreur peut se produire si vous avez entré des informations d'identification non valides pour le compte de service sous lequel l'instance d'hôte BizTalk s'exécute, ou si le compte de service ne dispose pas des droits de connexion en tant que service.

Résolution

Attribuez le droit de connexion en tant que service au compte de service de l'ordinateur distant avant de démarrer l'instance d'hôte BizTalk. Cela s'effectue automatiquement sur un ordinateur local, mais doit se faire manuellement sur un ordinateur distant.

Échec de la création ou de la configuration d'une instance d'hôte sur un ordinateur X64 avec l'option 32 bits seulement sélectionnée

Problème

Dans la console d’administration BizTalk Server, la création d’un instance d’hôte BizTalk sur un ordinateur X64 avec l’option 32 bits uniquement sélectionnée (par défaut) peut échouer.

Dans le gestionnaire de configuration de BizTalk Server, lorsque vous configurez le composant d'exécution de BizTalk Server sur un ordinateur X64, le fait de créer une instance d'hôte isolée ou de type In-process alors que l'option 32 bits seulement est sélectionnée risque de faire échouer le démarrage du service.

Cause

Unknown

Résolution

ce problème est intermittent. Réessayez de créer ou de configurer l'hôte, ou désélectionnez l'option 32 bits seulement.

La suppression de l'instance d'hôte Host n'efface pas les informations de registre

Problème

Si vous n'avez pas la qualité d'administrateur sur l'ordinateur local, un message d'erreur indiquant que l'accès est refusé s'affiche lorsque vous supprimez un hôte de type In-process ou isolé. Vous pouvez supprimer l'hôte de force. Toutefois, cette méthode n'efface pas toutes les informations de registre associées.

Cause

La suppression des informations de registre associées à une instance d'hôte requiert des privilèges d'administrateur.

Résolution

Connectez-vous en tant que compte d'administrateur local avant de supprimer l'hôte afin de supprimer également les informations de registre associées.

Impossible de supprimer une base de données MessageBox

Problème

Vous ne parvenez pas à supprimer une base de données MessageBox. L'échec de la suppression peut être dû à l'un des problèmes suivants :

  • L'intervalle d'actualisation du cache n'a pas expiré.

  • La base de données MessageBox contient des instances incomplètes.

    Si l’intervalle d’actualisation du cache n’a pas encore expiré, le message d’erreur suivant s’affiche lorsque la suppression échoue : « MessageBox ne peut pas être supprimé, car il peut y avoir du travail restant dans messageBox. Vérifiez qu’il n’y a plus d’instances incomplètes dans MessageBox, puis réessayez. »

Cause

L'intervalle d'actualisation du cache doit expirer entre le moment où vous désactivez la publication des nouveaux messages dans la base de données MessageBox et celui où vous supprimez la base de données. Par défaut, l’intervalle d’actualisation du cache est de 60 secondes.

Résolution

Pour supprimer une base de données MessageBox, vous devez d'abord désactiver la publication des nouveaux messages de celle-ci, puis patienter jusqu'à l'expiration de l'intervalle d'actualisation du cache.

Si la base de données MessageBox contient des instances de service incomplètes, le message d’erreur suivant s’affiche : « MessageBox ne peut pas être supprimé, car il peut toujours contenir des instances incomplètes. Assurez-vous qu'elle ne comporte plus aucune instance inachevée et recommencez. »

Vous pouvez afficher les instances de service incomplètes dans la base de données MessageBox à l'aide de la page Hub du groupe de la console Administration de BizTalk Server. Pour plus d’informations sur l’affichage du status d’instances de service dans la page Hub de groupe, consultez Guide pratique pour rechercher des instances de service suivies.

Voir aussi

Dépannage