Problèmes connus avec l'adaptateur SOAP
Cette section contient des informations qui peuvent vous permettre d'éviter certaines erreurs.
Problèmes connus
L'adaptateur SOAP rencontre des problèmes de performances ou génère des erreurs en conditions de charge
Problème
L'adaptateur SOAP rencontre des problèmes de performances ou génère des erreurs en conditions de charge
Cause
Ce problème survient car les options de configuration par défaut de l'adaptateur SOAP ou des composants de dépendances qui ont un impact sur l'adaptateur SOAP ne sont pas configurés pour les performances en cas de charge.
Résolution
Pour résoudre ce problème, modifiez les options de configuration de l’adaptateur SOAP ou des composants de dépendance décrits dans la rubrique Paramètres de configuration qui affectent les performances de l’adaptateur.
Les composants de pipeline Encodeur et Décodeur MIME/SMIME ne peuvent ni coder ni décoder les données traitées par l'adaptateur SOAP
Problème
Les composants de pipeline Encodeur et Décodeur MIME/SMIME ne peuvent ni coder ni décoder les données traitées par l'adaptateur SOAP
Cause
Ce problème se produit car l'adaptateur SOAP assemble et désassemble les messages SOAP dans l'étape du processus le concernant.
Résolution
Pour résoudre ce problème, utilisez SSL (Secure Sockets Layer) pour sécuriser les communications de codage des messages traités par l'adaptateur SOAP. Du côté de l’envoi, utilisez la propriété Empreinte numérique du certificat client dans la page propriétés de l’adaptateur SOAP pour ce faire. Au niveau de la réception, vous devez configurer le répertoire virtuel qui héberge le service Web BizTalk pour les communications SSL sécurisées.
Le domaine d'application AppDomain par défaut hébergeant l'adaptateur SOAP est déchargé, ce qui provoque le blocage du processus hôte
Problème
Le processus hébergeant l'adaptateur SOAP se bloque, ce qui provoque le blocage de tous les autres services Web du processus. Cela peut donner lieu à l'erreur suivante :
Il y a eu un échec lors de l’exécution du pipeline response(send) : « Unknown » Source : « Unknown » Port de réception : TwoWayLatencyLoopBack_RxPort » URI : « /TwoWayLatencyRxSOAP/TwoWayLatencyWS.asmx » Raison : Tentative d’accès à un AppDomain déchargé.
Cause
L'adaptateur SOAP s'exécute dans l'espace de processus IIS. Si le pool d'applications AppPool de IIS contient plusieurs services Web, chacun d'entre eux dispose au final de son propre AppDomain.
Par défaut, tous les objets du moteur de messagerie sont créés dans le premier AppDomain (c'est-à-dire, celui correspondant au premier service Web). Si le premier service Web est inactif pendant une période prolongée, quelle qu'en soit la raison, IIS décharge le premier AppDomain. Dans ce cas, tous les services du processus d'hébergement deviennent inutilisables.
Résolution
Pour éviter le déchargement du domaine d’application AppDomain, procédez comme suit :
Cliquez sur Démarrer, pointez sur Tous les programmes, sur Microsoft BizTalk Server, puis sur Administration BizTalk Server.
Dans BizTalk Server Console d’administration, développez Administration BizTalk Server, BizTalk Group, Paramètres de la plateforme, puis cliquez sur Hôtes.
Dans la liste des hôtes, cliquez avec le bouton droit sur l’hôte requis, puis cliquez sur Paramètres.
Dans le tableau de bord Paramètres BizTalk, case activée domaine d’application par défaut pour l’adaptateur isolé sous l’onglet Général.
Ceci fait, les objets du moteur de messagerie BizTalk sont créés dans le domaine d'application AppDomain par défaut et non dans leur propre AppDomains. Le domaine d'application AppDomain par défaut n'étant jamais déchargé, ce problème ne se produit plus.
Échec de l'inscription de l'adaptateur SOAP
Problème
L'erreur suivante peut se produire lorsque BizTalk Server tente d'inscrire l'adaptateur SOAP (ou HTTP).
« Le moteur de messagerie n'a pas pu inscrire l'adaptateur "SOAP". Détails : « L’inscription de plusieurs types d’adaptateurs dans le même processus n’est pas un scénario pris en charge. Ainsi, les adaptateurs de réception HTTP et SOAP ne peuvent pas coexister dans le même processus. »
ou
« Le moteur de messagerie n'a pas pu inscrire l'adaptateur "HTTP". Détails : « L’inscription de plusieurs types d’adaptateurs dans le même processus n’est pas un scénario pris en charge. Ainsi, les adaptateurs de réception HTTP et SOAP ne peuvent pas coexister dans le même processus. »
Cause
Lors de l'exécution de BizTalk Server sur Windows Server 2003 / IIS 6.x, les adaptateurs SOAP et HTTP ne peuvent pas s'exécuter dans le même espace de processus ou pool d'applications.
Résolution
Si une installation requiert l'utilisation des adaptateurs SOAP et HTTP sur le même serveur Web, des pools d'applications distincts doivent être créés pour chaque adaptateur. Une fois créés, les répertoires virtuels de chaque adaptateur sont chacun assignés à un pool d'applications différent.
Notes
Ce problème ne se produit pas sous Windows XP car, sous ce système d'exploitation, les adaptateurs SOAP et HTTP s'exécutent dans des espaces de processus différents sous IIS 5.x. L'adaptateur SOAP s'exécute en tant qu'application ASP.Net dans le processus aspnet_wp.exe. L'adaptateur HTTP s'exécute dans l'espace de processus dédié de dllhost.exe. Les deux adaptateurs sont donc isolés l'un de l'autre, et peuvent donc s'exécuter sur le même serveur Web simultanément.