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KB: Windows Update Standalone Installer (WUSA) returns 0x5 ERROR_ACCESS_DENIED when deploying .msu files through WinRM and Windows Remote Shell

imageHere’s a new Knowledge Base article we published. This one talks about an issue where Windows Update Standalone Installer (WUSA) returns 0x5 ERROR_ACCESS_DENIED when deploying Windows Update .msu files through Windows Remote Management.

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Symptoms

Windows Update Standalone Installer (WUSA) returns 0x5 ERROR_ACCESS_DENIED when deploying Windows Update .msu files through Windows Remote Management 2.0 and Windows Remote Shell. You may also see the following in the Application Event log:
Source: Microsoft-Windows-WUSAEvent ID: 3Level: ErrorDescription: Windows update could not be installed because of error 2147942405 "Access is denied."

Cause

Installing an update using WUSA or the WUA APIs on a remote machine is not supported.

Workaround

To work around this issue, use the following method:

Extract the .msu file through Windows Remote Shell with WUSA using the following command:

winrs.exe -r:<computername> wusa.exe <update> /extract:<destination>

When complete, install the .cab package with dism.exe or Package Manager. To use dism.exe, use the command below:

winrs.exe -r:<computername> dism.exe /online /add-package /PackagePath:<Path_To_Package>\KBnnnnnnn.cab

More Information

The Windows Update Standalone Installer uses the Windows Update Agent API to install update packages. Update packages have an .msu file name extension. The .msu file name extension is associated with the Windows Update Standalone Installer.

The security restrictions on remote use of the WUA APIs are documented here: https://msdn.microsoft.com/en-us/library/windows/desktop/aa387288(v=vs.85).aspx

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For the most current version of this article please see the following:

2773898 - Windows Update Standalone Installer (WUSA) returns 0x5 ERROR_ACCESS_DENIED when deploying .msu files through WinRM and Windows Remote Shell

J.C. Hornbeck | Knowledge Engineer | Management and Security Division

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