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MED-V Solution: Error When Starting Workspace: "Reply Message Didn't Arrive on Time"

image When you attempt to start a deployed workspace from a MED-V client or test a MED-V workspace using a test image, you may get the following error:

"Failed to start Workspace '<workspaceName>"

Details show:

"Unexpected error when trying to verify Workspace prerequisites. Internal error: Reply message didn't arrive on time. original message ID: <messageID GUID>"

Cause

This could be one of two possibilities:

1.) The MED-V Workspace is not installed inside of the virtual machine image.

2.) The MED-V client on the host needs more time to communicate with the MED-V workspace service. The Guest Virtual Machine may need to have more memory allocated to it. This can be controlled by the workspace policy.

Resolution

If the virtual machine image does not have the workspace installed prior to deployment, it will need to be installed inside the guest operating system and the image re-imported, repacked, and redeployed. For test images, this will require retesting with a new base image (that contains the installed workspace binaries).

You may also need to adjust the memory allocated to the virtual machine by the MED-V client. This can be configured within the MED-V workspace policy. For more information, please refer to the following TechNet documentation: https://technet.microsoft.com/en-us/library/ee348990.aspx

Steve Thomas | Senior Support Escalation Engineer