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Exchange Server 2016 の MSExchangeApplicationLogic / 3018 イベントについて

Exchange Server 2013 をご利用の方で、下記の「MSExchangeApplicationLogic / 3018 イベントについて」の記事をご存知の方もいらっしゃるかと思いますが、Exchange Server 2016 では、同じ対処を実施いただいても CU3 以前では引き続きイベントログにエラー ID:3018 が記録され、解消できない場合がございます。

Exchange Server 2013 への対処については下記の Blog を参照ください。

Titel:MSExchangeApplicationLogic / 3018 イベントについて
URL:https://blogs.technet.microsoft.com/exchangeteamjp/2014/10/22/msexchangeapplicationlogic-3018/

現象
Proxy サーバーを経由してインターネットへアクセスする環境で、Exchange Server 2016 に Proxy の設定を行っているにも関わらず、イベントログに ID:3018 のエラーが 1 時間に 2 回の頻度で記録されます。
この場合、WinHTTP Proxy の設定や、Internet Explorer の Proxy 設定、Set-ExchangeServer での Proxy のいずれを設定しても状況は変化しません。

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ログの名前: Application
ソース: MSExchangeApplicationLogic
イベント ID: 3018
レベル: エラー
説明:
corr=7b28dee1-e4de-4a96-9407-63684af49b3f&Client=WAC_Outlook&Scenario[ServiceHealth]: GetConfig。CorrelationId: 7b28dee1-e4de-4a96-9407-63684af49b3f。要求に失敗しました。メールボックス: URL: https://officeclient.microsoft.com/config16?CV=15.1.466.34 例外: System.Net.WebException: リモート名を解決できませんでした。: 'officeclient.microsoft.com'
場所 System.Net.HttpWebRequest.EndGetResponse(IAsyncResult asyncResult)
場所 Microsoft.Exchange.Data.ApplicationLogic.Extension.BaseAsyncOmexCommand.<>c__DisplayClass2.<EndGetResponseCallback>b__1()
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エラーの内容については、Exchange Server 2013 と同じ、Office ストアへのアクセスが失敗したことを示すものとなり、同エラーは 1 時間に 2 回記録されます。

原因
本事象は Exchange Server 2016 CU2 までは Proxy の設定を読み込む際の動作に起因した問題となります。
このイベントログのエラーが 1 時間に 2 回記録される理由としては、EWS と OWA のアプリケーションプールがそれぞれが 60 分間隔で Office ストアへのアクセスを実行しているためとなります。

この事象が発生している環境では、下記の対処法の実施を検討ください。

対処法
Exchange Server 2016 CU3 では Proxy の設定を読み込む際の処理が改善されております。
その為、イベント ID:3018 の出力を抑止される場合は、Exchange Server 2016 CU3 を適用し、Set-ExchangeServer コマンドより Proxy の設定を実施ください。

コマンド) Set-ExchangeServer -Identity  <サーバー名> -InternetWebProxy <プロキシ サーバー>
例) Set-ExchangeServer -Identity Server01 -InternetWebProxy https://proxy.contoso.com:8080

上記の対処を実施いただきますと、Office ストアへのアクセスに成功したことを示すイベント ID:3026 が出力されるようになります。

なお本件については、ID 3018 のエラーイベントが継続して記録され続けている場合でも、Exchange Server の稼働や Outlook/OWA などのクライアントからの接続などには影響はございません。
そのため、CU2 以前をご利用の環境でインターネットへの直接アクセスができない環境の場合は、イベントのエラーは無視していただいて構いません。

※本情報の内容(添付文書、リンク先などを含む)は、作成日時点でのものであり、予告なく変更される場合があります。