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Erreur « Demander à votre administrateur CRM d’accéder à Salesforce à l’aide d’API »

Cet article vous aide à résoudre les problèmes liés à l’affichage d’un message d’erreur après la connexion et la connexion à Salesforce CRM dans Microsoft Copilot for Sales.

Note

Microsoft Sales Copilot est renommé Microsoft Copilot for Sales en janvier 2024. Les captures d’écran de cet article seront bientôt mises à jour avec le nouveau nom.

Qui est affecté ?

Type de condition requise Description
Application cliente Complément Copilot for Sales Outlook
Plateforme Clients de bureau et web
Système d’exploitation Windows et Mac
Déploiement Géré par l’utilisateur et géré par l’administrateur
CRM Salesforce
Utilisateurs Utilisateurs qui tentent d’utiliser Copilot for Sales avec Salesforce CRM

Symptômes

Une fois que vous vous êtes connecté à Salesforce CRM via le complément Copilot for Sales pour Outlook, le message d’erreur suivant s’affiche :

Demander à votre administrateur CRM d’accéder à Salesforce à l’aide d’API

Capture d’écran montrant l’erreur d’autorisation de l’API.

Cause

Le problème se produit lorsque vous n’avez pas d’autorisations d’API dans Salesforce. Vous pouvez confirmer s’il s’agit de la cause principale du problème si vous voyez l’erreur suivante dans les journaux :

Exception thrown in VivaSalesContacts/GetContactsByEmailAddress - 
Microsoft.SalesProductivity.Common.Base.SPServiceException: Salesforce failed to complete task: Message: entity is deleted clientRequestId: {CLIENT REQUEST ID HERE}-self ---> 
System.Exception: { 
    "error": { 
        "code": 502, 
        "source": "{APIM SOURCE}", 
        "message": "BadGateway", 
        "innerError": { 
            "status": 502, 
            "message": "Salesforce failed to complete task: Message: **API is disabled for this User**\r\nclientRequestId: {CLIENT REQUEST ID HERE}", 
            "error": null, 
            "source": "Salesforce.Common", 
            "errors": [] 
        } 
    } 
} 

Résolution

Un administrateur peut accorder à l’API l’autorisation Activé pour l’utilisateur ou le profil de l’utilisateur concerné en procédant comme suit :

  1. Connectez-vous au Salesforce en tant qu’administrateur.

  2. Dans la zone de recherche, entrez Utilisateurs.

  3. Dans le volet de navigation gauche, sélectionnez Profils, puis sélectionnez le profil de l’utilisateur concerné.

  4. Dans la section Autorisations administratifs, sélectionnez API activée.

  5. Cliquez sur Enregistrer.

    Capture d’écran montrant l’option API Activée sur la page Profils.

Plus d’informations

Si votre problème n’est toujours pas résolu, accédez au Copilot for Sales - Microsoft Community Hub pour communiquer avec nos experts.

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