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Résolution des problèmes de compression de fichiers d’Azure Content Delivery Network

Important

Azure CDN Standard de Microsoft (classique) sera mis hors service le 30 septembre 2027. Pour éviter toute interruption de service, il est important de migrer votre profil Azure CDN Standard de Microsoft (classique) vers Azure Front Door Standard ou Premium avant le 30 septembre 2027. Pour découvrir plus d’informations, consultez Mise hors service d’Azure CDN Standard de Microsoft (classique).

Azure CDN d’Edgio a été mis hors service le 15 janvier 2025. Pour découvrir plus d’informations, consultez FAQ sur la mise hors service d’Azure CDN d’Edgio.

Cet article vous aide à résoudre les problèmes de compression des fichiers CDN.

Si vous avez besoin d'aide supplémentaire concernant n'importe quel point de cet article, contactez les experts Azure sur les forums MSDN Azure et Stack Overflow. Vous pouvez également signaler un incident au Support Azure. Accédez au site du support Azure, puis sélectionnez Obtenir un support.

Symptôme

La compression pour votre point de terminaison est activée, mais les fichiers sont renvoyés non compressés.

Conseil

Pour vérifier si vos fichiers sont retournés sous une forme compressée, vous devez utiliser un outil comme Fiddler ou les outils de développement de votre navigateur. Vérifiez les en-têtes de réponse HTTP retournés avec votre contenu de réseau de distribution de contenu mis en cache. S’il existe un en-tête nommé Content-Encoding avec une valeur gzip, bzip2, brotli ou deflate, votre contenu est compressé.

En-tête d’encodage de contenu

Cause

Il existe plusieurs causes possibles, y compris :

  • Le contenu demandé n’est pas éligible à la compression.
  • La compression n’est pas activée pour le type de fichier demandé.
  • La requête HTTP ne comprenait pas un en-tête demandant un type de compression valide.
  • L’origine envoie du contenu segmenté.

Étapes de dépannage

Conseil

Comme lors du déploiement de nouveaux points de terminaison, les modifications de configuration de réseau de distribution de contenu prennent un certain temps à se propager sur le réseau. En règle générale, les modifications sont appliquées dans les 90 minutes. Si c’est la première fois que vous avez configuré la compression pour votre point de terminaison de réseau de distribution de contenu, vous devez envisager d’attendre 1 à 2 heures pour être sûr que les paramètres de compression ont été propagés aux POP.

Vérifier la requête

Tout d’abord, effectuez une vérification rapide de l’intégrité de la requête. Vous pouvez utiliser les outils de développement de votre navigateur pour afficher les requêtes en cours.

  • Vérifiez que la requête est envoyée à l’URL de point de terminaison, <endpointname>.azureedge.net, et non à l’origine.
  • Vérifiez que la requête contient un en-tête Accept-Encoding et que la valeur de cet en-tête contient gzip, deflate, brotli ou bzip2.

En-têtes de requête CDN

Vérifier les paramètres de compression

Accédez à votre point de terminaison dans le portail Azure et sélectionnez Configurer .

  • Vérifiez que la compression est activée.
  • Vérifiez que le type MIME pour le contenu à compresser est inclus dans la liste des formats compressés.

Paramètres de compression CDN

Vérifiez la requête sur le serveur d’origine pour un en-tête Via

L’en-tête HTTP Via indique au serveur web que la requête est transmise par un serveur proxy. Par défaut, les serveurs web Microsoft IIS ne compressent pas les réponses quand la requête contient un en-tête Via. Pour modifier ce comportement, procédez comme suit :