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"Request your CRM administrator permissions to access Salesforce using APIs" error

This article helps you troubleshoot and resolve issues when an error message is displayed after connecting and signing in to Salesforce CRM in Microsoft Copilot for Sales.

Note

Microsoft Sales Copilot is rebranded as Microsoft Copilot for Sales in January 2024. The screenshots in this article will be updated with the new name soon.

Who is affected?

Requirement type Description
Client app Copilot for Sales Outlook add-in
Platform Web and desktop clients
OS Windows and Mac
Deployment User managed and admin managed
CRM Salesforce
Users Users trying to use Copilot for Sales with Salesforce CRM

Symptoms

After you sign in to Salesforce CRM through the Copilot for Sales add-in for Outlook, the following error message is displayed:

Request your CRM administrator permissions to access Salesforce using APIs

Screenshot that shows the API permission error.

Cause

The issue occurs when you don't have API permissions in Salesforce. You can confirm if this is the root cause of the issue if you see the following error in the logs:

Exception thrown in VivaSalesContacts/GetContactsByEmailAddress - 
Microsoft.SalesProductivity.Common.Base.SPServiceException: Salesforce failed to complete task: Message: entity is deleted clientRequestId: {CLIENT REQUEST ID HERE}-self ---> 
System.Exception: { 
    "error": { 
        "code": 502, 
        "source": "{APIM SOURCE}", 
        "message": "BadGateway", 
        "innerError": { 
            "status": 502, 
            "message": "Salesforce failed to complete task: Message: **API is disabled for this User**\r\nclientRequestId: {CLIENT REQUEST ID HERE}", 
            "error": null, 
            "source": "Salesforce.Common", 
            "errors": [] 
        } 
    } 
} 

Resolution

An admininstrator can grant the API Enabled permission to the user or the affected user's profile by following these steps:

  1. Sign in to Salesforce as an administrator.

  2. In the search box, enter User.

  3. In the left navigation pane, select Profiles, and then select the affected user's profile.

  4. In the Administrative Permissions section, select API Enabled.

  5. Select Save.

    Screenshot that shows the API Enabled option on the Profiles page.

More information

If your issue is still unresolved, go to the Copilot for Sales - Microsoft Community Hub to engage with our experts.

Third-party information disclaimer

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.