Third-party cookies or pop-up blocker errors when accessing Power Automate embedded experiences
This article helps fix common configuration problems that prevent Power Automate from starting in embedded experiences within other apps or websites.
Symptoms
When you access embedded instances of Power Automate, like within SharePoint, Power Apps, or through custom SDK integrations, you might receive a blank screen or have a screen that stays on the spinner.
Cause
These issues occur because third-party cookies are blocked in the web browser.
Resolution
Power Automate stores some data, such as user identity and preferences locally, using your browser's capabilities. Problems occur if the browser blocks the storage of such local data or third-party cookies set by Power Automate.
To solve the issues, go to the settings of the browser you're using, enable the third-party cookies, and make sure that the related sites aren't blocked for cookies.
Instructions for Microsoft Edge
Option 1: Enable storage of third-party cookies and local data for all sites
- Select Settings > Cookies and site permissions.
- Expand Manage and delete cookies and site data.
- Ensure the Block third-party cookies setting is disabled.
- If present, remove the following sites from the site-specific cookie configuration under Block and Clear on exit:
https://make.powerautomate.com
https://*.make.powerautomate.com
https://make.*.powerautomate.com
https://login.microsoftonline.com
Option 2: Create exceptions to allow storage of third-party cookies and local data for Power Automate and associated services
Note
The following steps require your Edge browser version to be 87 or above.
- Select Settings > Cookies and site permissions.
- Expand Manage and delete cookies and site data.
- Select Add under Allow and add:
[*.]powerautomate.com
- Select Clear browsing data on close.
- Ensure Cookies and other site data is disabled. If you want to keep it enabled, select Add instead, and then add:
[*.]powerautomate.com
Instructions for Google Chrome
Option 1: Enable storage of third-party cookies and local data for all sites
- Select Settings > Privacy and security.
- Expand Cookies and other site data.
- Make sure that Block third-party cookies or Block all cookies isn't selected.
- If present, remove the following sites from the site-specific cookie configuration under Sites that can always use cookies and Always clear cookies when windows are closed:
https://make.powerautomate.com
https://*.make.powerautomate.com
https://make.*.powerautomate.com
https://login.microsoftonline.com
Option 2: Create exceptions to allow storage of third-party cookies and local data for Power Automate and associated services
- Select Settings > Privacy and security.
- Expand Cookies and other site data.
- Go to Sites that can always use cookies, select Add, and then add:
[*.]powerautomate.com
- Make sure you select the Including third-party cookies on this site option when adding the site.