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"the following name already exists" error occurs during exports

Note

On September 1, 2023, we merged and renamed Dynamics 365 Marketing and Dynamics 365 Customer Insights. Dynamics 365 Marketing is now called Dynamics 365 Customer Insights - Journeys. Dynamics 365 Customer Insights is now called Dynamics 365 Customer Insights - Data. For more information, see Dynamics 365 Customer Insights FAQs.

If an export tries to create a new segment in the export destination, but there is already a segment with that name, then review all exports to that destination for segments that are exported several times.

Prerequisites

  • Administrator permissions in Dynamics 365 Customer Insights - Data or Contributor permissions with the ability to share access to the connection used for this export
  • The name mentioned in the error message

Symptoms

A specific export run fails, and you receive the "the following name already exists" error message followed by the output table name of a specific segment.

Cause

If this error message repeatedly occurs across system refreshes, then it's likely that your exports are set up to export the same segment several times to the same destination, which in rare cases can cause this error message.

Resolution

To resolve this issue,

  1. Note the name mentioned in the error message.
  2. Review the list of exported segments for all exports to the export destination that shows the error message.
  3. If you find the same segment selected in different exports, change the exports so that each segment is exported only once.
  4. Save changes to exports.
  5. The next time all exports run, confirm that the error doesn't occur.