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"Failed to enable your replication" error occurs in Cloud Migration Setup

This article solves an error message that occurs when you run the Cloud Migration Setup assisted setup guide in Business Central.

Symptoms

When you run the Cloud Migration Setup assisted setup guide during the data migration process from on-premises to Business Central online, you receive the following error message:

Failed to enable your replication. Make sure your integration runtime is successfully connected and try again.

Cause

There can be several reasons for the error message. But the most common reason is a mismatch between the on-premises version and the online Business Central versions and the Product Type chosen in the Cloud Migration Setup guide.

Resolution

Run Cloud Migration Setup, and when you get to the Choose Your Product page, make sure the Product Type is consistent with your on-premises and online versions. Business Central version numbers should have the Major.Minor.Revision.Build format, such as 20.1.12345.67890.

  • If the on-premises and online major versions are the same, like 20.1 for on-premises and 20.3 for online, choose Dynamics Business Central current version.
  • If the on-premises and online major versions are different, like 14.3 for on-premises and 20.3 for online, choose Dynamics Business Central earlier versions.

You can run the following SQL query to verify the on-premises database contains the correct version number:

SELECT [applicationversion]
FROM [$ndo$tenantdatabaseproperty]