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Troubleshoot the "Quotaexceeded" error code

This article discusses how to identify and resolve the "QuotaExceeded" error that occurs when you try to upgrade an Azure Kubernetes Service (AKS) cluster.

Here's an example of the error message:

Operation results in exceeding quota limits of Core. Maximum allowed: X, Current in use: X, Additional requested: X

Prerequisites

This article requires Azure CLI version 2.0.65 or a later version. To find the version number, run az --version. If you have to install or upgrade Azure CLI, see How to install the Azure CLI.

For more detailed information about the upgrade process, see the "Upgrade an AKS cluster" section in Upgrade an Azure Kubernetes Service (AKS) cluster.

Symptoms

An AKS cluster upgrade fails, and you receive a "QuotaExceeded" error message.

Cause

The issue occurs if the quota is reached. Your subscription doesn't have available resources that are required for upgrading.

Solution

To raise the limit or quota for your subscription, go to the Azure portal and file a Service and subscription limits (quotas) support ticket. In this case, you have to submit a support ticket to increase the quota for compute cores.

Contact us for help

If you have questions or need help, create a support request, or ask Azure community support. You can also submit product feedback to Azure feedback community.