Jaa


Yhdistelmähaku ei onnistu indeksoimaan tai palauttamaan tuloksia

Oireet

Saatat kohdata yhden tai useamman seuraavista ongelmista käyttäessäsi yhdistelmähakua SharePointissa Microsoft 365:ssä:

  • Indeksointi epäonnistuu.
  • Tulosta ei palauteta.
  • Näyttöön tulee virhesanoma, kuten "Aiemmin luotu yhteys suljettiin väkisin".

Syy

Olemme aloittaneet TLS 1.1:n ja 1.0:n poistamisen Microsoft 365:ssä. 30.6.2021 alkaen hakupalvelu ei enää hyväksy yhteyksiä, jotka käyttävät TLS 1.1:ta tai 1.0:aa. Jos käytät Cloud hakupalvelu -sovellusta (SSA) Vanhemmissa Windows-versioissa, sinun on otettava TLS 1.2 manuaalisesti käyttöön, jotta paikallinen sisältö indeksoidtaan SharePointissa Microsoft 365:ssä.

Ratkaisu

Voit korjata tämän ongelman ottamalla TLS 1.2:n käyttöön noudattamalla seuraavia ohjeita:

Huomautus

Jos nämä ongelmat jatkuvat Windows Server 2012:ssa tai Windows Server 2008 R2 SP1:ssä, kokeile seuraavia ratkaisuja:

Tarkista myös tuetut salakirjoituspaketit ja salakirjoitusohjelmiston lajittelujärjestys. TLS 1.2:ssa Azure Front Door tukee seuraavia salausohjelmistoja:

  • TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384
  • TLS_ECDHE_RSA_WITH_AES_128_GCM_SHA256
  • TLS_DHE_RSA_WITH_AES_256_GCM_SHA384
  • TLS_DHE_RSA_WITH_AES_128_GCM_SHA256

Jos haluat lisätä salauspaketteja, ota käyttöön ryhmäkäytäntö -asetus tai käytä Paikallista ryhmäkäytäntö Kirjoitusavustaja kohdassa TLS-salausohjelmistotilauksen määrittäminen ryhmäkäytäntö avulla kuvatulla tavalla.

Tärkeää

Muuta salakirjoitusohjelmistojen järjestystä varmistaaksesi, että nämä neljä sviittiä ovat listan kärjessä (suurin prioriteetti).

Lisätietoja on artikkelissa Mitä nykyisiä salakirjoituspaketteja Azure Front Door tukee?.

Lisätietoja

Tarvitsetko lisää ohjeita? Siirry SharePointin yhteisöön.