Jaa


"0xC004F038: Tietokonetta ei voitu aktivoida" -virhe KMS-aktivoinnissa

Tämän artikkelin on kirjoittanut Eric Ashton, vanhempi tuen eskalointiinsinööri.

Oireet

Yrität aktivoida Microsoft Office 2013:n tai Office 2016:n Avaintenhallintapalvelun (KMS) isännän kautta millä tahansa seuraavista tavoista:

  • Volyymiaktivoinnin hallintatyökalu (VAMT)
  • Officen ohjattu aktivointitoiminto asiakastietokoneesta
  • OSPP.vbs /act-komentosarja

Näyttöön tulee kuitenkin seuraava virhesanoma:

0xC004F038: Ohjelmiston käyttöoikeuspalvelu ilmoitti, että tietokonetta ei voitu aktivoida. Avaintenhallintapalvelun (KMS) ilmoittama määrä ei ole riittävä. Ota yhteyttä järjestelmänvalvojaan.

Syy

Tämä ongelma ilmenee, koska Office KMS -varanto sisältää alle viisi yksilöllistä asiakastietokonetta.

Ratkaisu

Voit ratkaista tämän ongelman suurentamalla Office KMS -varannon asiakastietokoneiden määrän vähintään viiteen.

Huomautus

Voit selvittää, kuinka monta asiakastietokonetta ON tällä hetkellä KMS-isännän Office KMS -varannossa, suorittamalla seuraavan komennon laajennetussa komentokehoteikkunassa kohteesta c:\windows\system32 ja painamalla sitten Enter-näppäintä:

Cscript slmgr.vbs -dlv all >c:\temp\KMSInfo.txt

Siirry osoitteeseen c:\temp (tai mihin tahansa mukautettuun sijaintiin, johon siirrät tulosteen) ja avaa sitten KMSInfo.txt. Etsi Office KMS -isännän asennustiedot etsimällä Office. Tarkista Nykyinen määrä - arvo. Jos Office KMS -määrä on pienempi kuin 5, Office-asiakasohjelmat eivät aktivoidu.

Kun Office KMS -varanto sisältää vähintään viisi asiakastietokonetta, yritä aktivoida Office käyttämällä Officen ohjattua aktivointitoimintoa ,OSPP.vbstai VAMT:tä.

Jos käytät järjestelmän valmistelua (Sysprep) ympäristössäsi, On mahdollista, että Officea ei järjestelty uudelleen ennen kuvan luomista. Tämän vuoksi tietokoneilla voi olla sama asiakastietokonetunnus (CMID) Officelle.

Jos sinulla on yli viisi tietokonetta, jotka yrittävät aktivoida, ja näet edelleen tämän virhesanoman, tarkista KMS-isännän Tapahtumienvalvonta KMS-palvelimessa. Näet esimerkiksi merkinnät, jotka muistuttavat seuraavaa:

  • 0x0,5,Ignite1.ignite.local,930bd202-a335-4c7e-bd9d-7305361f0d37,Päivämäärä/aika,0,5,0,6f327760-8c5c-417c-9b61-836a98287e0c
  • 0x0,5,Ignite2.ignite.local,2f362dd3-fb39-4d18-94e6-de1d30dd27d5,,Päivämäärä/aika,0,5,0,6f327760-8c5c-417c-9b61-836a98287e0c
  • 0x0,5,Ignite5.ignite.local,930bd202-a335-4c7e-bd9d-7305361f0d37,Päivämäärä/aika,0,5,0,6f327760-8c5c-417c-9b61-836a98287e0c

Huomaa tässä esimerkissä, että Ignite5:llä ja ignite1:llä on sama CMID (930bd202-a335-4c7e-bd9d-7305361f0d37). Tämä tarkoittaa sitä, että Officen takaosa ohitettiin, vaikka peruskäyttöjärjestelmän kuva on ehkä luotu.

Huomautus

Ennen kuin Sysprep valmistelee kuvan, varmista, että suoritat jonkin seuraavista komennoista Office-bittiversiosi perusteella, jotta saat yksilöllisen Office CMID -tunnuksen.

  • 32-bittinen Office

    C:\Program Files (x86)\Microsoft Office\Office16\ospprearm.exe

  • 64-bittinen Office

    C:\Program Files\Microsoft Office\Office16\ospprearm.exe

Lisätietoja Office-asennuksen uudelleenjärjestelystä on seuraavissa artikkeleissa:

Voit suorittaa seuraavan käynnistyskomentosarjan näissä tietokoneissa, jos haluat järjesteleä Officen uudelleen ja luoda uusia, yksilöllisiä Office-tunnuksia. Korvaa tässä komentosarjassa XX sopivalla arvolla Office-versiosi perusteella:

XX = 15 Office 2013:ssa

XX = 16 Office 2016:ssa

@echo off

:OSPP 

reg query HKLM\Software\Microsoft\Office\XX.0\Common\OSPPREARM if %errorlevel%==1 (goto RUN) else (goto END)

:RUN set ProgramFilesPath=%ProgramFiles% 

"%ProgramFilesPath%\Microsoft Office\OfficeXX\OSPPREARM.EXE"

C:\Windows\system32\cscript.exe "%ProgramFilesPath%\Microsoft Office\OfficeXX\ospp.vbs" /act set ProgramFilesPath=%ProgramFiles(x86)%

"%ProgramFilesPath%\Microsoft Office\OfficeXX\OSPPREARM.EXE"

C:\Windows\system32\cscript.exe "%ProgramFilesPath%\Microsoft Office\OfficeXX\ospp.vbs" /act REG ADD "HKLM\Software\Microsoft\Office\XX.0\Common\OSPPREARM"

:END

Exit