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Windows 10 1511 がソフトウェア更新プログラムのスキャンに失敗する

こんにちは。System Center Configuration Manager サポート チームです。

 

System Center Configuration Manager  (以下、SCCM ) クライアントがWindows 10 バージョン 1511 である場合、接続先となるソフトウェアの更新ポイント (WSUS) サーバーにおいて、"Upgrades" を同期対象にしていると、更新プログラムのスキャンに失敗するという既知の問題があります。

 

本事象が発生すると、スキャンが失敗しクライアントに最新のソフトウェア更新プログラムが展開されませんので該当するクライアントがある場合は注意が必要です。

 

発生する条件は、以下のとおりです。
・クライアントが Windows 10 バージョン 1511 であること
・ソフトウェア更新ポイント (WSUS サーバー) が製品: Windows 10 , 分類: Upgrades を同期していること

 

上記の条件に該当する場合は、本事象が発生している可能性がありますので、下記の概要および回避策の内容をご確認ください。

 

概要

Windows 10 バージョン 1511 のクライアントが、ソフトウェア更新プログラムのスキャンに失敗します。
本問題が発生した場合、クライアントの WUAHandler.log (C:\Windows\CCM\Logs に存在します)には、以下のログが記録されます。

 

Scan failed with error = 0x80240fff.

 

また WindowsUpdate.log にも以下のログが記録されます。

08/04/2016-13:22:23.609 0FA8 0D9C Agent    Excluding update 15A3B6FB-57DC-4FF3-8511-4AD934A7B883.202 from search results because it is only in excluded categories.
08/04/2016-13:22:23.609 0FA8 0D9C Agent    Excluding update 808C89FF-93AF-405D-9317-2CDCE1E30DB4.202 from search results because it is only in excluded categories.
08/04/2016-13:22:23.609 0FA8 0D9C Agent    Two Swap OSUpgrades are found, Update1 = {9E7A3076-1062-4ED7-8ACA-9ED8051A199F}.200, Update2 = {82E85185-F5C8-4537-8A88-8D5A7BFB3FAA}.200
08/04/2016-13:22:23.609 0FA8 0D9C Agent    FilterInappropriateOSUpgrade failed, hr=80240FFF
08/04/2016-13:22:23.609 0FA8 0D9C Agent    Failed to filter search results with error 80240FFF

 

補足情報: Windows 10 で WindowsUpdate.log を確認する方法は、以下をご参照ください。

Windows 10, WindowsUpdate.log and how to view it with PowerShell or Tracefmt.exe

 

原因

クライアントが 2 つ以上のバージョンの機能更新プログラム (Windows 10 バージョン 1607 および 1703 および 1709) を検索した場合、ソフトウェア更新プログラムのスキャンが失敗する動作に起因しております。この問題となる動作については、 2017 年 3 月 にリリースされた更新プログラム KB4013198 によって修正されています。

 

回避策

方法1. クライアントに 2017 年 3 月 にリリースされた更新プログラム KB4013198をインストールする
(2017 年 3 月以降にリリースされた累積の更新プログラムでも構いません。)

 

方法2. ソフトウェア更新ポイント (WSUS )サーバーで、2 つの機能更新プログラムのうち、1つの更新プログラムを拒否済みにする
Windows 10 バージョン 1607 を展開する必要がない場合は、次の手順でバージョン 1607 の機能更新プログラムを拒否済みにしてください。

 

- 方法 2 の具体的な手順
1. WSUS 管理コンソールを開き、拒否をする機能更新プログラムを表示します。

右ペインの [検索] オプションを使用する場合は、下記のキーワードで検索をします。
”Feature update to Windows 10 Enterprise, version 1607, ja-jp“
”Feature update to Windows 10 Pro, version 1607, ja-jp“

 

2. 機能更新プログラムを選択し、右クリック - [拒否] から拒否済みに設定します。

上記を実施頂いた後、SCCM 管理コンソール上にてすべての更新プログラムの同期を行います。

 

3. SCCM 管理コンソールから、以下の場所に移動します。
[ソフトウェア ライブラリ] – [概要] – [Windows 10 のサービス] – [すべての Windows 10 更新プログラム]

 

4. メニュー左上から、[ソフトウェア更新プログラムの同期] をクリックします。

拒否済みにした機能更新プログラムが、SCCM管理コンソール上では 「期限切れ」を意味する黒い [×] アイコンとなっていれば完了です。

対処方法は以上となります。

 

クライアントで、すぐに問題の解消を確認したい場合は、コントロール パネルの [システムとセキュリティ] より Configuration Manager を開き、[操作] タブから [ソフトウェア更新プログラムのスキャン サイクル] を選択し [直ちに実行] をクリックしてください。実行後、スキャンがエラーなく終了すれば本問題は解消していると言えます。

その後は、既定で 60 分に 1 回実行されるコンピューター ポリシーの取得が完了すれば、更新プログラムの展開が始まります。

直ちに実行したい場合は、[操作] タブから [コンピューター ポリシーの取得および評価サイクル] と [ソフトウェア更新プログラムの展開評価サイクル] を選択し、[直ちに実行] をクリックする作業を年度か実施いただいた後、更新プログラムのダウンロードとインストールが開始されるかご確認ください。