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Solution: Connecting to BMC Remedy via Opalis Integration Server fails with "Connection test failed"

toolsignHere's a solution we ran across the other day and since I didn't see it published here I thought it would be worth a mention.

Symptoms

You may be unable to connect to BMC Remedy via Opalis Integration Server.  When you attempt to do so you receive the following error when testing the BMC Remedy Connection:

Connection test failed. Please make sure that the server name, username, password and application are correct.

Details: AR System call failed. Details:
Message number: 90:
Cannot open catalog; Message number = 90
HOSTNAME.com : RPC: Rpcbind failure - RPC: Unable to receive

The following error is also received when attempting to enumerate the catalog from the BMC Connection Settings page:

Unable to connect to the AR System server and as a result the application list is not available.

Cause

Error 90 within BMC Remedy indicates a network connection or interruption error has occurred.  This issue often occurs when using a non-standard port to connect to BMC Remedy.  If the Portmapper service is not running,  an environment variable must be defined in order for Opalis to successfully connect to BMC Remedy using the non-standard TCP port. 

Resolution

In order to successfully connect Opalis Integration Server to BMC Remedy using a non-standard connection port, the following environment variable must be defined on the Opalis Action Server from where the connection originates.

Variable: ARTCPPORT
Value: <Port Number>

Once the appropriate system environment variable has been set, reboot the server and test the connection to BMC Remedy once again.  The connection should complete a test successfully with the variable defined.

Hope this helps,

Nicholas Dodge | Senior Support Escalation Engineer

The App-V Team blog: https://blogs.technet.com/appv/
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The SCMDM Support Team blog: https://blogs.technet.com/mdm/
The ConfigMgr Support Team blog: https://blogs.technet.com/configurationmgr/
The SCOM 2007 Support Team blog: https://blogs.technet.com/operationsmgr/
The SCVMM Team blog: https://blogs.technet.com/scvmm/
The MED-V Team blog: https://blogs.technet.com/medv/
The DPM Team blog: https://blogs.technet.com/dpm/
The OOB Support Team blog: https://blogs.technet.com/oob/
The Opalis Team blog: https://blogs.technet.com/opalis

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Comments

  • Anonymous
    November 03, 2010
    Hi there, Although true (for older versions of the BMC Remedy IP), this workaround is no longer required when using the latest BMC Remedy IP! In the newer version (we're running 5.40), an option is provided to define the ARTCPPORT to be used. Although this is system wide for each connection, one can define different connections for different ARSystems (each having their own ARTCPPORT). Dealing with different environments (ie. Development, Test and Production) may pose an issue though. If you migrate a policy from Development to Test or Production and you have to select a different connection, all information stored in the BMC Remedy IP objects are thrown away :-( My advise would be to use different Opalis environments as well and name the connection between the environments all equal. If you do not have to change the connection used in the Remedy IP Objects, all information below is saved, enabling one to export / import policies from Development to Test / or Production. Do not hesitate to get in touch for further information. Regards, Rob.