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Support-Tip (INSTALLATION): Failed to connect to the specified database

PRODUCTS INVOLVED

  • Microsoft Forefront Identity Manager 2010, R2, R2 SP1
  • Microsoft Identity Manager 2016, SP1

PROBLEM SCENARIO DESCRIPTION

  • During the installation of the Synchronization Service Manager and/or the Service and Portal you receive error messages indicating a problem connecting to the database.

CAUSE

  • There are several reasons that this happens during the installation.

RESOLUTION ITEMS

  1. Ensure that the account executing the installation is a SA on the backend SQL Server.
    1. The following Microsoft TechNet Wiki assists with some account information to help prepare you for the actual installation.  https://social.technet.microsoft.com/wiki/contents/articles/7222.fim-2010-installation-companion-accounts.aspx
  2. Ensure that you have the Microsoft .NET Framework v3.5 installed on the Synchronization Service machine.
    1. You can do this through Roles and Features in Server Manager
  3. Ensure that you have the Microsoft SQL Server Native Client Installed on the Synchronization Service Manager machine.
  4. Ensure that port 1433, which is default for SQL Server is open in the Firewall.
  5. If you are using a non-standard SQL Server Port, please be sure to create a client side alias using the cliconfig tool.

ADDITIONAL INFORMATION

 

 

KEYWORDS iamsupport, sync, install, connect to database