Users in cloud (Office 365) unable to book conference rooms on Exchange 2003 on-premise
Symptom
Office 365 Exchange Online users cannot book conference rooms that resides in Exchange Server 2003 server on-premise in Hybrid deployment.
Cause
The issue occurs because Auto Accept Agent is not installed.
Resolution
To work around the issue, move the resource mailbox to Exchange Server 2010 mailbox server.
Note: The Auto Accept Agent is configured by default in Exchange Server 2010.
More Information
Understanding Auto Accept Agent
https://technet.microsoft.com/en-us/library/bb124617(v=exchg.65).aspx
Exchange 2003 Auto Accept Agent vs. direct booking
https://blogs.technet.com/b/exchange/archive/2006/02/22/420275.aspx
Applies To
Office 365 Exchange Online