Retention policy does not work automatically in Exchange Online for Office 365
Symptom
In Microsoft Exchange Online for Microsoft Office 365, you apply a retention policy that moves email messages from a user’s mailbox to the archive mailbox. In this scenario, the retention policy does not automatically run.
Cause
The issue occurs because the retention policy runs automatically one time every 7 days for mailboxes that are larger than 10 MB. However, the retention policy does not automatically run for mailboxes that are smaller than 10 MB or within 7 days’ work cycle.
Resolution
To resolve the issue, manually run Start-ManagedFolderAssistant –Identity <mailbox> cmdlet to force Managed Folder Assistant to process the specific mailbox in Exchange Online for Office 365.
//To resolve the issue, follow the steps:
1. Connect Windows PowerShell to cloud-based service.
2. Manually run Start-ManagedFolderAssistant –Identity <mailbox> cmdlet to force Managed Folder Assistant to process the specific mailbox.
More Information
Messages are not automatically moved to a user's archive mailbox after you create a retention policy in Exchange Online for Office 365
https://support.microsoft.com/kb/2627729
Start-ManagedFolderAssistant
https://technet.microsoft.com/en-us/library/aa998864.aspx
Set Up and Manage Retention Policies in Exchange Online
https://technet.microsoft.com/en-sg/exchangelabshelp/gg271153#defaulttags
Connect Windows PowerShell to the Service
https://help.outlook.com/en-us/140/cc952755.aspx
Applies To
Office 365 Exchange Online
Comments
Anonymous
June 29, 2012
Well it very technical enough and supportive. I will try the steps and if fail will contact you. you may also need to visit http://www.ambrina.com for further troubleshooting.Anonymous
December 04, 2014
asda